aboutsummaryrefslogtreecommitdiff
path: root/audio/play
diff options
context:
space:
mode:
Diffstat (limited to 'audio/play')
-rw-r--r--audio/play/Makefile26
-rw-r--r--audio/play/distinfo2
-rw-r--r--audio/play/files/patch-encode__riff.c54
-rw-r--r--audio/play/files/patch-play.c10
-rw-r--r--audio/play/pkg-descr2
5 files changed, 0 insertions, 94 deletions
diff --git a/audio/play/Makefile b/audio/play/Makefile
deleted file mode 100644
index 5512670547e1..000000000000
--- a/audio/play/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# Created by: Masanori Kiriake <seiken@nbs.co.jp>
-
-PORTNAME= play
-PORTVERSION= 1.0
-PORTREVISION= 1
-CATEGORIES= audio
-MASTER_SITES= PORTS_JP
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Simple audio file player
-
-CONFLICTS= sox-[0-9]*
-
-USES= uidfix
-MAKE_ARGS= CFLAGS="${CFLAGS}" MANDIR="${PREFIX}/man/ja/man" BINDIR="${PREFIX}/bin"
-# XXX PIE static libraries are not supported by base system /usr/share/mk
-MAKE_ARGS+= WITHOUT_PIE=true
-
-PLIST_FILES= bin/play man/ja/man1/play.1.gz
-
-post-patch:
-.for file in play_audio.c mixer_ctl.c encode_sun.c encode_riff.c speed.c
- @${REINPLACE_CMD} '/soundcard\.h/s,machine,sys,' ${WRKSRC}/${file}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/audio/play/distinfo b/audio/play/distinfo
deleted file mode 100644
index 46289a7e9b34..000000000000
--- a/audio/play/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (play-1.0.tar.gz) = 13d0af4be4e22a267b1b3c195b5bdfaefd1b10d9f51df9c0fa4b25edecbb3d7b
-SIZE (play-1.0.tar.gz) = 6301
diff --git a/audio/play/files/patch-encode__riff.c b/audio/play/files/patch-encode__riff.c
deleted file mode 100644
index 9965314a2953..000000000000
--- a/audio/play/files/patch-encode__riff.c
+++ /dev/null
@@ -1,54 +0,0 @@
---- encode_riff.c.orig 1997-03-25 15:25:07 UTC
-+++ encode_riff.c
-@@ -11,7 +11,7 @@ static char rcsid[] =
- #include <signal.h>
- #include <err.h>
-
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
-
- #include "play.h"
- #include "encode_riff.h"
-@@ -74,7 +74,7 @@ int play_riff(char *audio_file, riff_hea
- char *bufp;
- char *device;
- int devfd, filefd;
-- int stat, len, buf_size, format, data_length;
-+ int stat, len, buf_size, format = 0, data_length;
-
- if (!f_hasdsp) {
- fprintf(stderr, "%s: %s: needs DSP for play\n", myname, audio_file);
-@@ -109,7 +109,12 @@ int play_riff(char *audio_file, riff_hea
- warn("%s", device);
- stat = FAIL; goto failplay0;
- }
-+#if 0
-+ /* this (at least under fbsd) means that you want to set play format
-+ * to headerp->sample_size which is a nonsense */
- if (ioctl(devfd, SNDCTL_DSP_SAMPLESIZE, &headerp->sample_size) < 0) {
-+#endif
-+ if (ioctl(devfd, SNDCTL_DSP_SAMPLESIZE, &format) < 0) {
- warn("%s", device);
- stat = FAIL; goto failplay0;
- }
-@@ -121,11 +126,6 @@ int play_riff(char *audio_file, riff_hea
- warn("%s", device);
- stat = FAIL; goto failplay0;
- }
-- /* XXX */
-- if (ioctl(devfd, SNDCTL_DSP_SETFMT, &format) < 0) {
-- warn("%s", device);
-- stat = FAIL; goto failplay0;
-- }
- if (headerp->channels > 1) {
- int ch = headerp->channels;
- if (ioctl(devfd, SNDCTL_DSP_STEREO, &ch) < 0) {
-@@ -163,6 +163,8 @@ int play_riff(char *audio_file, riff_hea
- warn("read");
- stat = FAIL; goto failplay2;
- }
-+/* printf("len = %10d, len = %10d\n", stat, len); */
-+ stat = (len < stat)? len : stat;
- if (write(devfd, bufp, stat) < 0) {
- warn("write");
- stat = FAIL; goto failplay2;
diff --git a/audio/play/files/patch-play.c b/audio/play/files/patch-play.c
deleted file mode 100644
index e8a74e8aa5e8..000000000000
--- a/audio/play/files/patch-play.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- play.c.orig 1997-03-25 15:25:12 UTC
-+++ play.c
-@@ -4,6 +4,7 @@ static char rcsid[] = "$Id: play.c,v 1.7
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include <fcntl.h>
- #include <err.h>
- #include <signal.h>
diff --git a/audio/play/pkg-descr b/audio/play/pkg-descr
deleted file mode 100644
index 1a200961d14d..000000000000
--- a/audio/play/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-play is a command-line based audio player.
-supported formats: RIFF and U-Law.