aboutsummaryrefslogtreecommitdiff
path: root/audio/py-pyacoustid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-pyacoustid/Makefile')
-rw-r--r--audio/py-pyacoustid/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/audio/py-pyacoustid/Makefile b/audio/py-pyacoustid/Makefile
index d0d2db32748e..d0785a3973a3 100644
--- a/audio/py-pyacoustid/Makefile
+++ b/audio/py-pyacoustid/Makefile
@@ -1,22 +1,25 @@
-# Created by: Mark Felder <feld@FreeBSD.org>
-
PORTNAME= pyacoustid
-PORTVERSION= 1.2.0
+PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= audio python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Bindings for Chromaprint acoustic fingerprinting and the Acoustid API
+WWW= https://github.com/beetbox/pyacoustid
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libchromaprint.so:audio/chromaprint
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}audioread>=0:audio/py-audioread@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USES= python
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes