aboutsummaryrefslogtreecommitdiff
path: root/audio/py-pylast/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-pylast/Makefile')
-rw-r--r--audio/py-pylast/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/audio/py-pylast/Makefile b/audio/py-pylast/Makefile
index e503961d5252..93742925f0d0 100644
--- a/audio/py-pylast/Makefile
+++ b/audio/py-pylast/Makefile
@@ -1,22 +1,28 @@
-# Created by: Mark Felder <feld@FreeBSD.org>
-
PORTNAME= pylast
-PORTVERSION= 4.2.1
+PORTVERSION= 5.2.0
CATEGORIES= audio python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python interface to Last.fm and Libre.fm
+WWW= https://github.com/pylast/pylast
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-vcs>=0:devel/py-hatch-vcs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httpx>=0:www/py-httpx@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flaky>=0:devel/py-flaky@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-random-order>=0:devel/py-pytest-random-order@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USES= python
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
.include <bsd.port.mk>