aboutsummaryrefslogtreecommitdiff
path: root/audio/rubberband/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rubberband/Makefile')
-rw-r--r--audio/rubberband/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/audio/rubberband/Makefile b/audio/rubberband/Makefile
index 06d7504a9bbb..8a11c9ba2813 100644
--- a/audio/rubberband/Makefile
+++ b/audio/rubberband/Makefile
@@ -1,12 +1,11 @@
-# Created by: mathias.picker@gmx.de
-
PORTNAME= rubberband
-DISTVERSION= 1.9.2
+DISTVERSION= 3.3.0
CATEGORIES= audio
MASTER_SITES= https://breakfastquay.com/files/releases/
MAINTAINER= acm@FreeBSD.org
COMMENT= Audio time-stretching and pitch-shifting library and utility program
+WWW= https://breakfastquay.com/rubberband/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -22,6 +21,12 @@ USES= localbase meson pkgconfig tar:bzip2
USE_LDCONFIG= yes
MESON_ARGS= -Dfft=fftw \
- -Dresampler=libsamplerate
+ -Dresampler=libsamplerate \
+ -Djni=disabled
+
+OPTIONS_DEFINE= TEST
+
+TEST_BUILD_DEPENDS= boost-libs>0:devel/boost-libs
+TEST_MESON_ENABLED= tests
.include <bsd.port.mk>