aboutsummaryrefslogtreecommitdiff
path: root/audio/snack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/snack/Makefile')
-rw-r--r--audio/snack/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index ec86b6e1914e..bdad31f72fca 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -7,16 +7,22 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Sound toolkit for scripting languages
+WWW= https://www.speech.kth.se/snack/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/../COPYING
-USES= tk:tea
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= tk:tea xorg
USE_LDCONFIG= ${PREFIX}/lib/snack${PORTVERSION:R}
+USE_XORG= x11 xscrnsaver xext xft xrender
+
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
-WRKSRC_SUBDIR= unix
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC_SUBDIR= unix
PLIST_SUB= SNACK_VER=${PORTVERSION:R}
PORTDOCS= *
@@ -29,6 +35,12 @@ VORBIS_CONFIGURE_ON= --with-ogg-include=${LOCALBASE}/include \
--with-ogg-lib=${LOCALBASE}/lib
VORBIS_ALL_TARGET= all libsnackogg.so
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/snack${PORTVERSION:R}/*.so