aboutsummaryrefslogtreecommitdiff
path: root/audio/ssr-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ssr-lv2/Makefile')
-rw-r--r--audio/ssr-lv2/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/audio/ssr-lv2/Makefile b/audio/ssr-lv2/Makefile
new file mode 100644
index 000000000000..20f0657fa350
--- /dev/null
+++ b/audio/ssr-lv2/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= ssr
+DISTVERSION= g20210922
+PORTREVISION= 1
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Sympathetic string resonator LV2 plugin
+WWW= https://github.com/jpcima/ssr
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64 i386 powerpc64le powerpc64 powerpc # same as in sysutils/libcpuid because libcpuid is bundled in ssr
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ bash:shells/bash
+LIB_DEPENDS= libjack.so:audio/jack
+
+USES= compiler:c++11-lang gmake gnome pkgconfig shebangfix xorg
+USE_GNOME= cairo
+USE_XORG= x11
+
+USE_GITHUB= yes
+GH_ACCOUNT= jpcima
+GH_TAGNAME= e1999da
+GH_TUPLE= DISTRHO:DPF:220d364:dpf/dpf
+
+SHEBANG_FILES= dpf/utils/generate-ttl.sh
+
+CFLAGS+= -I${FILESDIR}
+
+PLIST_FILES= bin/ssr \
+ lib/lv2/ssr.lv2/manifest.ttl \
+ lib/lv2/ssr.lv2/ssr_dsp.so \
+ lib/lv2/ssr.lv2/ssr_dsp.ttl \
+ lib/lv2/ssr.lv2/ssr_ui.so \
+ lib/lv2/ssr.lv2/ssr_ui.ttl
+
+.include <bsd.port.mk>