aboutsummaryrefslogtreecommitdiff
path: root/audio/stk
diff options
context:
space:
mode:
Diffstat (limited to 'audio/stk')
-rw-r--r--audio/stk/Makefile34
-rw-r--r--audio/stk/distinfo6
-rw-r--r--audio/stk/files/patch-configure101
-rw-r--r--audio/stk/files/patch-configure.ac60
-rw-r--r--audio/stk/pkg-descr2
-rw-r--r--audio/stk/pkg-plist2
6 files changed, 129 insertions, 76 deletions
diff --git a/audio/stk/Makefile b/audio/stk/Makefile
index 2a41aaff0f85..d42978ae4002 100644
--- a/audio/stk/Makefile
+++ b/audio/stk/Makefile
@@ -1,29 +1,43 @@
-# Created by: Yuri Victorovich <yuri@rawbw.com>
-
PORTNAME= stk
-PORTVERSION= 4.6.1
-PORTREVISION= 2
+DISTVERSION= 5.0.1
CATEGORIES= audio
MASTER_SITES= http://ccrma.stanford.edu/software/stk/release/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Synthesis ToolKit in C++
+WWW= https://ccrma.stanford.edu/software/stk
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libjack.so:audio/jack
-
-USES= autoreconf compiler:c++11-lang dos2unix gmake localbase pkgconfig
+USES= compiler:c++11-lang dos2unix gmake localbase pkgconfig
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-jack --with-oss
+
DOS2UNIX_GLOB= *.cpp *.h
+
+GNU_CONFIGURE= yes
+
MAKE_ARGS= RAWWAVES=${DATADIR}/rawwaves/
+LDFLAGS+= -pthread
+
+OPTIONS_RADIO= BACKEND
+OPTIONS_RADIO_BACKEND= JACK OSS
+OPTIONS_DEFAULT= JACK
+
+BACKEND_DESC= Audio Backend
+
+JACK_CONFIGURE_WITH= jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+
+OSS_CONFIGURE_WITH= oss
+# OSS option appears to make real-time functionality in STK broken
+# (example https://www.music.mcgill.ca/~gary/618/week2/node16.html),
+# also see https://github.com/thestk/stk/issues/141#issuecomment-1673488078
+
post-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} rawwaves ${STAGEDIR}${DATADIR}
@${RM} ${STAGEDIR}${DATADIR}/rawwaves/._* ${STAGEDIR}${DATADIR}/rawwaves/*.c
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libstk-${PORTVERSION}.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libstk-5.0.0.so
.include <bsd.port.mk>
diff --git a/audio/stk/distinfo b/audio/stk/distinfo
index c59296eb7a15..f2ee5b5bc754 100644
--- a/audio/stk/distinfo
+++ b/audio/stk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1556434208
-SHA256 (stk-4.6.1.tar.gz) = e77ba3c80cdd93ca02c34098b9b7f918df3d648c87f1ed5d94fe854debd6d101
-SIZE (stk-4.6.1.tar.gz) = 2593348
+TIMESTAMP = 1691726894
+SHA256 (stk-5.0.1.tar.gz) = afc35faea3bb8baacacb8d9db3fa745e4f7d8dd46f36aac5436ca377d565a184
+SIZE (stk-5.0.1.tar.gz) = 2786068
diff --git a/audio/stk/files/patch-configure b/audio/stk/files/patch-configure
new file mode 100644
index 000000000000..dca9a1948cc7
--- /dev/null
+++ b/audio/stk/files/patch-configure
@@ -0,0 +1,101 @@
+--- configure.orig 2023-08-04 15:25:31 UTC
++++ configure
+@@ -6220,7 +6220,7 @@ then :
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: using OSS" >&5
+ printf "%s\n" "using OSS" >&6; }
+ api="$api -D__LINUX_OSS__"
+- LIBS="$LIBS -lossaudio"
++ #LIBS="$LIBS -lossaudio"
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for pthread_create in -lpthread" >&5
+ printf %s "checking for pthread_create in -lpthread... " >&6; }
+ if test ${ac_cv_lib_pthread_pthread_create+y}
+@@ -6228,7 +6228,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6260,7 +6260,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
+@@ -6276,7 +6276,7 @@ then :
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: using OSS" >&5
+ printf "%s\n" "using OSS" >&6; }
+ api="$api -D__LINUX_OSS__"
+- LIBS="$LIBS -lossaudio"
++ #LIBS="$LIBS -lossaudio"
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for pthread_create in -lpthread" >&5
+ printf %s "checking for pthread_create in -lpthread... " >&6; }
+ if test ${ac_cv_lib_pthread_pthread_create+y}
+@@ -6284,7 +6284,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6316,7 +6316,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
+@@ -6325,7 +6325,7 @@ fi
+ fi
+ ;;
+
+- *-*-linux*)
++ *-*-linux* | *-*-freebsd*)
+ # Look for ALSA flag
+
+ # Check whether --with-alsa was given.
+@@ -6617,7 +6617,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6649,7 +6649,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
+@@ -6711,7 +6711,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6743,7 +6743,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
diff --git a/audio/stk/files/patch-configure.ac b/audio/stk/files/patch-configure.ac
deleted file mode 100644
index 92b5739b525f..000000000000
--- a/audio/stk/files/patch-configure.ac
+++ /dev/null
@@ -1,60 +0,0 @@
---- configure.ac.orig 2017-09-01 00:28:55 UTC
-+++ configure.ac
-@@ -85,7 +85,6 @@ if test "$debug" = "yes"; then
- else
- AC_SUBST( debug, [no] )
- AC_SUBST( cppflag, [] )
-- AC_SUBST( cxxflag, [-O3] )
- AC_SUBST( object_path, [Release] )
- fi
- AC_MSG_RESULT($debug)
-@@ -100,7 +99,7 @@ fi
- CPPFLAGS="$CPPFLAGS $cppflag"
-
- # For debugging and optimization ... overwrite default because it has both -g and -O2
--CXXFLAGS="$cxxflag"
-+CXXFLAGS="$CXXFLAGS $cxxflag"
-
- # Check compiler and use -Wall if gnu.
- if [test $GXX = "yes" ;] then
-@@ -134,27 +133,27 @@ api="$api -D__UNIX_JACK__"
- AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))])
-
- case $host in
-- *-*-linux*)
-+ *-*-linux*|*-*-freebsd*)
- # Look for ALSA flag
-- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)])
-- AS_IF([test "x$with_alsa" == "xyes"], [
-- api="$api -D__LINUX_ALSA__"
-- AC_MSG_RESULT(using ALSA)
-- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
-+ #AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)])
-+ #AS_IF([test "x$with_alsa" == "xyes"], [
-+ #api="$api -D__LINUX_ALSA__"
-+ #AC_MSG_RESULT(using ALSA)
-+ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
-
- # Look for OSS flag
- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (unixes only)])
- AS_IF([test "x$with_oss" == "xyes"], [
-- api="$api -D__LINUX_OSS__ -D__LINUX_ALSA__"
-+ api="$api -D__LINUX_OSS__"
- AC_MSG_RESULT(using OSS)
-- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(OSS support requires ALSA for RtMidi!))])
-+ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(OSS support requires ALSA for RtMidi!))])
-
- # If no audio api flags specified, use ALSA
-- AS_IF([test "$api" == ""], [
-- AC_MSG_RESULT(using ALSA)
-- AC_SUBST( api, [-D__LINUX_ALSA__] )
-- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
-- ])
-+ #AS_IF([test "$api" == ""], [
-+ # AC_MSG_RESULT(using ALSA)
-+ # AC_SUBST( api, [-D__LINUX_ALSA__] )
-+ # AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
-+ #])
-
- AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
- ;;
diff --git a/audio/stk/pkg-descr b/audio/stk/pkg-descr
index beda19204257..88f54ef99e16 100644
--- a/audio/stk/pkg-descr
+++ b/audio/stk/pkg-descr
@@ -1,5 +1,3 @@
The Synthesis ToolKit in C++ (STK) is a set of open source audio signal
processing and algorithmic synthesis classes written in the C++ programming
language.
-
-WWW: https://ccrma.stanford.edu/software/stk
diff --git a/audio/stk/pkg-plist b/audio/stk/pkg-plist
index 81f7dd5d8d8b..82bd26ecb01f 100644
--- a/audio/stk/pkg-plist
+++ b/audio/stk/pkg-plist
@@ -102,7 +102,7 @@ include/stk/Whistle.h
include/stk/Wurley.h
include/stk/WvIn.h
include/stk/WvOut.h
-lib/libstk-4.6.1.so
+lib/libstk-5.0.0.so
lib/libstk.so
%%DATADIR%%/rawwaves/ahh.raw
%%DATADIR%%/rawwaves/bassdrum.raw