aboutsummaryrefslogtreecommitdiff
path: root/audio/taglib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/taglib/Makefile')
-rw-r--r--audio/taglib/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/audio/taglib/Makefile b/audio/taglib/Makefile
index af79923635dd..261a5dedcb22 100644
--- a/audio/taglib/Makefile
+++ b/audio/taglib/Makefile
@@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= taglib
-PORTVERSION= 1.10
+PORTVERSION= 1.11.1
CATEGORIES= audio
MASTER_SITES= http://taglib.github.io/releases/
MAINTAINER= jhale@FreeBSD.org
COMMENT= Library for manipulating ID3 tags and Ogg comments
-LICENSE= LGPL21 MPL
+LICENSE= LGPL21 MPL11
LICENSE_COMB= dual
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LGPL
LICENSE_FILE_MPL= ${WRKSRC}/COPYING.MPL
USES= cmake cpe pathfix
CMAKE_ARGS= -DWITH_ASF:BOOL=ON \
- -DWITH_MP4:BOOL=ON
+ -DWITH_MP4:BOOL=ON \
+ -DBUILD_SHARED_LIBS:BOOL=ON
+
USE_LDCONFIG= yes
CPE_VENDOR= scott_wheeler
@@ -24,6 +26,12 @@ CPE_VENDOR= scott_wheeler
OPTIONS_DEFINE= RCC
OPTIONS_SUB= yes
+# The official patches for this can be obtained from:
+# http://darksoft.org/files/rusxmms/patches/
+# however, they do not seem to yet have any for taglib-1.11.1.
+# So instead, use:
+# https://sourceforge.net/p/qmmp-dev/code/HEAD/tree/trunk/extras/package/win32/contrib/taglib-rusxmms/
+#
RCC_DESC= Build with RusXMMS librcc patches (experimental)
RCC_LIB_DEPENDS= librcc.so:devel/librcc
RCC_EXTRA_PATCHES= ${FILESDIR}/extrapatch-rcc