aboutsummaryrefslogtreecommitdiff
path: root/audio/zrythm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/zrythm/Makefile')
-rw-r--r--audio/zrythm/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/audio/zrythm/Makefile b/audio/zrythm/Makefile
index 733bf955ddbc..798dc5554eb6 100644
--- a/audio/zrythm/Makefile
+++ b/audio/zrythm/Makefile
@@ -1,10 +1,12 @@
PORTNAME= zrythm
DISTVERSIONPREFIX= v
-DISTVERSION= 1.0.0-alpha.25.1.22
+DISTVERSION= 1.0.0-alpha.26.0.13
+PORTREVISION= 11
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Modern music production system, also known as DAW
+WWW= https://www.zrythm.org/en/
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -21,7 +23,6 @@ LIB_DEPENDS= libaudec.so:audio/libaudec \
libcurl.so:ftp/curl \
libfftw3_threads.so:math/fftw3 \
libfftw3f_threads.so:math/fftw3-float \
- libguile-2.2.so:lang/guile2 \
libjack.so:audio/jack \
libjson-glib-1.0.so:devel/json-glib \
liblilv-0.so:audio/lilv \
@@ -46,13 +47,15 @@ LIB_DEPENDS= libaudec.so:audio/libaudec \
RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
-USES= compiler:c11 desktop-file-utils gettext-tools gettext-runtime gnome libtool localbase:ldflags \
- meson pkgconfig python:3.5+,build shared-mime-info shebangfix xorg
+USES= compiler:c11 desktop-file-utils gettext-tools gettext-runtime \
+ guile:2.2,3.0,alias,conflicts gnome libtool localbase:ldflags \
+ meson pkgconfig python:build shared-mime-info shebangfix xorg
USE_GITHUB= yes
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview3 libxml2 pango
USE_XORG= x11
SHEBANG_FILES= scripts/collect_translatables.sh
+MESON_ARGS= -Dlsp_dsp=disabled
GLIB_SCHEMAS= org.zrythm.Zrythm.gschema.xml
@@ -60,12 +63,6 @@ LDFLAGS+= ${LOCALBASE}/lib/libfftw3_threads.so ${LOCALBASE}/lib/libfftw3f_thread
BINARY_ALIAS= git=false python3=${PYTHON_CMD}
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc64
-MESON_ARGS= -Db_lto=false
-.endif
-
post-patch: # https://git.zrythm.org/zrythm/zrythm/issues/299
@${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/ext/midilib/src/*.c