aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/netperf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/netperf/Makefile')
-rw-r--r--benchmarks/netperf/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index 768c9a85bd5c..0e2031b6f7f2 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -1,17 +1,18 @@
-# Created by: koshy
-
PORTNAME= netperf
-PORTVERSION= 2.7.1.p20170921
-PORTREVISION= 1
+PORTVERSION= 2.7.1.p20210121
+PORTREVISION= 2
CATEGORIES= benchmarks
MAINTAINER= marius@FreeBSD.org
COMMENT= Network performance benchmarking package
+WWW= https://hewlettpackard.github.io/netperf/
+
+USES= autoreconf:build,2.69
USE_GITHUB= yes
GH_ACCOUNT= HewlettPackard
#GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
-GH_TAGNAME= d566775bf
+GH_TAGNAME= 3bc455b23
OPTIONS_DEFINE= EXAMPLES EXS HISTOGRAM INFO OMNI SCTP SOCKETS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
@@ -24,9 +25,8 @@ SOCKETS_DESC= Enable Unix Domain socket support
USE_CSTD= gnu89
GNU_CONFIGURE= yes
-CONFIGURE_ENV= "transform="
-CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
- --enable-demo --enable-burst --enable-intervals
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
+CONFIGURE_ARGS= --enable-burst --enable-demo --enable-dirty --enable-intervals
CFLAGS+= -fcommon
INFO_INFO= netperf
@@ -47,6 +47,10 @@ post-patch:
.for i in ${SCRIPTS}
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/doc/examples/$i
.endfor
+ @${REINPLACE_CMD} -E -e 's,(conf|header),\12.69,g' ${WRKSRC}/autogen.sh
+
+pre-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}