aboutsummaryrefslogtreecommitdiff
path: root/biology/dsr-pdb
diff options
context:
space:
mode:
Diffstat (limited to 'biology/dsr-pdb')
-rw-r--r--biology/dsr-pdb/Makefile8
-rw-r--r--biology/dsr-pdb/files/patch-lib_Makefile.in13
-rw-r--r--biology/dsr-pdb/pkg-descr2
3 files changed, 19 insertions, 4 deletions
diff --git a/biology/dsr-pdb/Makefile b/biology/dsr-pdb/Makefile
index 873e2c2a4e12..a84b48dd8241 100644
--- a/biology/dsr-pdb/Makefile
+++ b/biology/dsr-pdb/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dsr-pdb
DISTVERSION= 1.0.3
-PORTREVISION= 5
+PORTREVISION= 12
CATEGORIES= biology
MASTER_SITES= https://graphics.stanford.edu/~drussel/
DISTNAME= ${PORTNAME}
@@ -8,16 +8,20 @@ DIST_SUBDIR= ${PORTNAME}-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Simple C++ PDB reader (reads the protein description format)
+WWW= https://graphics.stanford.edu/~drussel/pdb/
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.txt
+BROKEN_aarch64= ld: error: undefined symbol: .mcount (see bug#262709)
+
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
USES= compiler:c++11-lang gmake libtool localbase:ldflags tar:tgz
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CXXFLAGS+= -fPIC --std=c++11 # libboost_program_options.so isn't found without --std=c++11
diff --git a/biology/dsr-pdb/files/patch-lib_Makefile.in b/biology/dsr-pdb/files/patch-lib_Makefile.in
new file mode 100644
index 000000000000..58a5ed2003b5
--- /dev/null
+++ b/biology/dsr-pdb/files/patch-lib_Makefile.in
@@ -0,0 +1,13 @@
+- workaround for https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=262709
+
+--- lib/Makefile.in.orig 2022-03-22 00:02:00 UTC
++++ lib/Makefile.in
+@@ -180,7 +180,7 @@ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ lib_LTLIBRARIES = libdsrpdb.la
+ noinst_HEADERS = pdb_utils.h Residue_data.h
+-AM_CPPFLAGS = -I../include -pg
++AM_CPPFLAGS = -I../include
+ libdsrpdb_la_SOURCES = Residue.cc Protein.cc Residue_data.cc Protein_pdb.cc pdb_utils.cc Model.cc PDB.cc align.cc distance.cc Error_logger.cc
+ libdsrpdb_la_LDFLAGS = -static
+ all: all-am
diff --git a/biology/dsr-pdb/pkg-descr b/biology/dsr-pdb/pkg-descr
index 4cc497313c13..09bf048c3180 100644
--- a/biology/dsr-pdb/pkg-descr
+++ b/biology/dsr-pdb/pkg-descr
@@ -8,5 +8,3 @@ protein from/to a pdb file (which must have only one chain, but can have
multiple models). The second, through the PDB class can handle pdb files with
multiple models and herogens (although these are just passed through and not
currently interpreted).
-
-WWW: https://graphics.stanford.edu/~drussel/pdb/