aboutsummaryrefslogtreecommitdiff
path: root/biology/fastp
diff options
context:
space:
mode:
Diffstat (limited to 'biology/fastp')
-rw-r--r--biology/fastp/Makefile8
-rw-r--r--biology/fastp/distinfo6
-rw-r--r--biology/fastp/files/patch-Makefile47
-rw-r--r--biology/fastp/files/patch-src_main.cpp17
-rw-r--r--biology/fastp/pkg-descr2
5 files changed, 57 insertions, 23 deletions
diff --git a/biology/fastp/Makefile b/biology/fastp/Makefile
index 2b8ec0278e58..ddd4d84876b1 100644
--- a/biology/fastp/Makefile
+++ b/biology/fastp/Makefile
@@ -1,15 +1,19 @@
PORTNAME= fastp
DISTVERSIONPREFIX= v
-DISTVERSION= 0.22.0
+DISTVERSION= 0.23.4
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
COMMENT= Ultra-fast all-in-one FASTQ preprocessor
+WWW= https://github.com/OpenGene/fastp
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lang gmake
+LIB_DEPENDS= libdeflate.so:archivers/libdeflate \
+ libisal.so:devel/isa-l
+
+USES= gmake localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= OpenGene
diff --git a/biology/fastp/distinfo b/biology/fastp/distinfo
index 3ecec1406b78..1c215d4d8906 100644
--- a/biology/fastp/distinfo
+++ b/biology/fastp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1630006835
-SHA256 (OpenGene-fastp-v0.22.0_GH0.tar.gz) = a7ef81cc39daed7ac6bfc254697345c448095539e1b5b45f3a8ab286098be456
-SIZE (OpenGene-fastp-v0.22.0_GH0.tar.gz) = 141257
+TIMESTAMP = 1685547158
+SHA256 (OpenGene-fastp-v0.23.4_GH0.tar.gz) = 4fad6db156e769d46071add8a778a13a5cb5186bc1e1a5f9b1ffd499d84d72b5
+SIZE (OpenGene-fastp-v0.23.4_GH0.tar.gz) = 164071
diff --git a/biology/fastp/files/patch-Makefile b/biology/fastp/files/patch-Makefile
index 595fdc96c6e6..da927edbe011 100644
--- a/biology/fastp/files/patch-Makefile
+++ b/biology/fastp/files/patch-Makefile
@@ -1,42 +1,57 @@
---- Makefile.orig 2020-04-08 07:26:52 UTC
+--- Makefile.orig 2021-10-19 02:19:29 UTC
+++ Makefile
-@@ -3,9 +3,11 @@ DIR_SRC := ./src
+@@ -2,11 +2,13 @@ DIR_INC := ./inc
+ DIR_SRC := ./src
DIR_OBJ := ./obj
- PREFIX ?= /usr/local
-+DESTDIR ?=
- BINDIR ?= $(PREFIX)/bin
- INCLUDE_DIRS ?=
- LIBRARY_DIRS ?=
-+STRIP_CMD ?= strip
+-PREFIX ?= /usr/local
+-BINDIR ?= $(PREFIX)/bin
+-INCLUDE_DIRS ?=
+-LIBRARY_DIRS ?=
++PREFIX ?= /usr/local
++BINDIR ?= $(PREFIX)/bin
++INCLUDE_DIRS ?=
++LIBRARY_DIRS ?=
++STRIP ?= strip
++
SRC := $(wildcard ${DIR_SRC}/*.cpp)
OBJ := $(patsubst %.cpp,${DIR_OBJ}/%.o,$(notdir ${SRC}))
-@@ -15,13 +17,14 @@ TARGET := fastp
+
+@@ -15,15 +17,19 @@ TARGET := fastp
BIN_TARGET := ${TARGET}
CXX ?= g++
--CXXFLAGS := -std=c++11 -g -O3 -I${DIR_INC} $(foreach includedir,$(INCLUDE_DIRS),-I$(includedir)) ${CXXFLAGS}
+-CXXFLAGS := -std=c++11 -pthread -g -O3 -I${DIR_INC} $(foreach includedir,$(INCLUDE_DIRS),-I$(includedir)) ${CXXFLAGS}
++# Optional flags that the user can override by setting CXXFLAGS in the
++# env or make argument
+CXXFLAGS ?= -g -O3
++# Required flags
+CXXFLAGS += -std=c++11 -I${DIR_INC} $(foreach includedir,$(INCLUDE_DIRS),-I$(includedir))
- LIBS := -lz -lpthread
+ LIBS := -lisal -ldeflate -lpthread
+ STATIC_FLAGS := -static -Wl,--no-as-needed -pthread
-LD_FLAGS := $(foreach librarydir,$(LIBRARY_DIRS),-L$(librarydir)) $(LIBS) $(LD_FLAGS)
++# Append required flags to standard LDFLAGS from env
+LDFLAGS += $(foreach librarydir,$(LIBRARY_DIRS),-L$(librarydir)) $(LIBS)
+ STATIC_LD_FLAGS := $(foreach librarydir,$(LIBRARY_DIRS),-L$(librarydir)) $(STATIC_FLAGS) $(LIBS) $(STATIC_LD_FLAGS)
-
+-
${BIN_TARGET}:${OBJ}
- $(CXX) $(OBJ) -o $@ $(LD_FLAGS)
+ $(CXX) $(OBJ) -o $@ $(LDFLAGS)
- ${DIR_OBJ}/%.o:${DIR_SRC}/%.cpp make_obj_dir
- $(CXX) -c $< -o $@ $(CXXFLAGS)
-@@ -38,5 +41,8 @@ make_obj_dir:
+ static:${OBJ}
+ $(CXX) $(OBJ) -o ${BIN_TARGET} $(STATIC_LD_FLAGS)
+@@ -49,6 +55,11 @@ make_obj_dir:
+ mkdir $(DIR_OBJ) ; \
fi
++# Respect DESTDIR for staged installs (used by most package managers)
install:
- install $(TARGET) $(BINDIR)/$(TARGET)
+ install $(TARGET) $(DESTDIR)$(BINDIR)/$(TARGET)
@echo "Installed."
+
++# Many package managers use install-strip target if debugging is not enabled
+install-strip: install
-+ $(STRIP_CMD) $(DESTDIR)$(BINDIR)/$(TARGET)
++ $(STRIP) $(DESTDIR)$(BINDIR)/$(TARGET)
diff --git a/biology/fastp/files/patch-src_main.cpp b/biology/fastp/files/patch-src_main.cpp
new file mode 100644
index 000000000000..28e5bf918991
--- /dev/null
+++ b/biology/fastp/files/patch-src_main.cpp
@@ -0,0 +1,17 @@
+--- src/main.cpp.orig 2021-10-19 02:19:29 UTC
++++ src/main.cpp
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <sysexits.h>
+ #include "fastqreader.h"
+ #include "unittest.h"
+ #include <time.h>
+@@ -18,7 +19,7 @@ int main(int argc, char* argv[]){
+ if(argc == 1) {
+ cerr << "fastp: an ultra-fast all-in-one FASTQ preprocessor" << endl << "version " << FASTP_VER << endl;
+ //cerr << "fastp --help to see the help"<<endl;
+- //return 0;
++ return EX_USAGE;
+ }
+ if (argc == 2 && strcmp(argv[1], "test")==0){
+ UnitTest tester;
diff --git a/biology/fastp/pkg-descr b/biology/fastp/pkg-descr
index e64bd53e0e9c..e799d025d69d 100644
--- a/biology/fastp/pkg-descr
+++ b/biology/fastp/pkg-descr
@@ -1,5 +1,3 @@
fastp is a tool designed to provide fast all-in-one preprocessing for FastQ
files. This tool is developed in C++ with multithreading supported to afford
high performance.
-
-WWW: https://github.com/OpenGene/fastp