aboutsummaryrefslogtreecommitdiff
path: root/biology/freebayes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/freebayes/Makefile')
-rw-r--r--biology/freebayes/Makefile53
1 files changed, 24 insertions, 29 deletions
diff --git a/biology/freebayes/Makefile b/biology/freebayes/Makefile
index 225643cec02b..9ca877a4c665 100644
--- a/biology/freebayes/Makefile
+++ b/biology/freebayes/Makefile
@@ -1,7 +1,6 @@
PORTNAME= freebayes
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.0
-PORTREVISION= 3
+DISTVERSION= 1.3.5
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -9,46 +8,42 @@ COMMENT= Bayesian haplotype-based polymorphism discovery and genotyping
LICENSE= MIT
-BROKEN_aarch64= fails to compile: invalid conversion between vector type and integer type
+# These should be rechecked: Same error resolved on aarch64 in 1.3.5 update.
BROKEN_armv6= fails to compile: invalid conversion between vector type and integer type
BROKEN_armv7= fails to compile: invalid conversion between vector type and integer type
BROKEN_riscv64= fails to compile: invalid conversion between vector type and integer type
+LIB_DEPENDS= libhts.so:biology/htslib \
+ libtabix.so:biology/tabixpp
+
# Submodules use older versions than the ports, so we cannot safely unbundle
# No shared libs are built by the submodules so there will be no conflicts
-USES= compiler:c++11-lang gmake tar:xz
+USES= compiler:c++14-lang localbase meson perl5 pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= ekg
-GH_TUPLE= walaj:SeqLib:5941c68:SeqLib/SeqLib-temp \
- jwalabroad:bwa:c02766e:bwa/SeqLib/bwa \
- jwalabroad:fermi-lite:5bc90f8:fermi/SeqLib/fermi-lite \
- samtools:htslib:49fdfbd:htslib/SeqLib/htslib \
- ekg:bamtools:e77a43f:bamtools/bamtools \
- ekg:intervaltree:dbb4c51:interval1/intervaltree \
- vcflib:vcflib:5e3ce04:vcflib/vcflib-temp \
- ekg:fastahack:c68cebb:fastahack/vcflib/fastahack \
- ekg:filevercmp:1a9b779:filevercmp/vcflib/filevercmp \
+GH_TUPLE= ekg:vcflib:d4073c3:vcflib/vcflib-temp \
+ ekg:smithwaterman:2610e25:smithwaterman/vcflib/smithwaterman \
+ ekg:multichoose:68733cd:multichoose/vcflib/multichoose \
+ ekg:fastahack:bb33265:fastahack/vcflib/fastahack \
+ ekg:intervaltree:17ddd57:intervaltree/vcflib/intervaltree \
ekg:fsom:a6ef318:fsom/vcflib/fsom \
- google:googletest:d225acc:google/vcflib/googletest \
- ekg:intervaltree:b704f19:interval2/vcflib/intervaltree \
- ekg:multichoose:73d35da:multichoose/vcflib/multichoose \
- ekg:smithwaterman:84c08d7:smithwaterman/vcflib/smithwaterman \
- ekg:tabixpp:80012f8:tabixpp/vcflib/tabixpp \
- samtools:htslib:0f298ce:hts2/vcflib/tabixpp/htslib
-
-# GCC disables sse2 by default on i386, but it's required for vcflib
-CXXFLAGS+= --std=c++11
-CFLAGS_i386= -msse2
-MAKE_JOBS_UNSAFE= yes
+ ekg:filevercmp:1a9b779:filevercmp/vcflib/filevercmp \
+ google:googletest:d225acc:googletest/vcflib/googletest \
+ edawson:libVCFH:615a06b:libVCFH/vcflib/libVCFH \
+ simd-everywhere:simde-no-tests:2931676:simd/vcflib/src/simde \
+ ekg:intervaltree:b90527f:intervaltree2/intervaltree \
+ ekg:tabixpp:b255df1:tabixpp/vcflib/tabixpp \
+ ingydotnet:test-simple-bash:124673f:testsimplebash/test/test-simple-bash \
+ illusori:bash-tap:c38fbfa:bashtap/test/bash-tap \
+ samtools:htslib:b581944:htslib/contrib/htslib
+USE_PERL5= build
+
+LDFLAGS+= -lexecinfo
PLIST_FILES= bin/bamleftalign bin/freebayes
# GH_TUPLEs cannot seem to share a top-level subdirectory, so we work around
# by dumping the parent in a temp directory and then moving the contents
post-extract:
- ${MV} -n ${WRKSRC}/SeqLib-temp/* ${WRKSRC}/SeqLib
- ${MV} -n ${WRKSRC}/vcflib-temp/* ${WRKSRC}/vcflib
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
+ ${CP} -r ${WRKSRC}/vcflib-temp/* ${WRKSRC}/vcflib
.include <bsd.port.mk>