aboutsummaryrefslogtreecommitdiff
path: root/biology/htslib
diff options
context:
space:
mode:
Diffstat (limited to 'biology/htslib')
-rw-r--r--biology/htslib/Makefile10
-rw-r--r--biology/htslib/distinfo6
-rw-r--r--biology/htslib/files/patch-Makefile37
-rw-r--r--biology/htslib/files/patch-htscodecs_htscodecs_rANS__static32x16pr__neon.c11
-rw-r--r--biology/htslib/files/patch-htscodecs_htscodecs_rANS__static4x16pr.c11
-rw-r--r--biology/htslib/pkg-descr2
-rw-r--r--biology/htslib/pkg-plist14
7 files changed, 48 insertions, 43 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index ec7ab0ab4d8d..5a844cef433c 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -1,13 +1,13 @@
-# Created by: Reed A. Cartwright <cartwright@asu.edu>
-
PORTNAME= htslib
-DISTVERSION= 1.13
+DISTVERSION= 1.17
+PORTREVISION= 1
CATEGORIES= biology devel
# Github generated distfiles are incomplete, so use custom tarball
MASTER_SITES= https://github.com/samtools/htslib/releases/download/${DISTVERSION}/
MAINTAINER= jwb@FreeBSD.org
COMMENT= C library for high-throughput sequencing data formats
+WWW= https://www.htslib.org/
LICENSE= BSD3CLAUSE MIT
LICENSE_COMB= multi
@@ -21,6 +21,10 @@ USE_PERL5= test
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
+MAKE_ARGS_armv6= HTS_HAVE_NEON=
+MAKE_ARGS_armv7= HTS_HAVE_NEON=
+MAKE_ARGS= $(MAKE_ARGS_$(ARCH))
PATHFIX_MAKEFILEIN= Makefile
SHEBANG_FILES= test/*.pl
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
index dc4bf1b4ea09..24c398cacc3c 100644
--- a/biology/htslib/distinfo
+++ b/biology/htslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626039683
-SHA256 (htslib-1.13.tar.bz2) = f2407df9f97f0bb6b07656579e41a1ca5100464067b6b21bf962a2ea4b0efd65
-SIZE (htslib-1.13.tar.bz2) = 4226834
+TIMESTAMP = 1677245487
+SHA256 (htslib-1.17.tar.bz2) = 763779288c40f07646ec7ad98b96c378c739171d162ad98398868783b721839f
+SIZE (htslib-1.17.tar.bz2) = 4619884
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index 7f91465d2ccd..eb6fb7f85901 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,33 +1,14 @@
---- Makefile.orig 2021-03-20 15:53:14 UTC
+--- Makefile.orig 2023-02-24 13:35:28 UTC
+++ Makefile
-@@ -53,13 +53,14 @@ man5dir = $(mandir)/man5
- man7dir = $(mandir)/man7
- pkgconfigdir= $(prefix)/libdata/pkgconfig
-
--MKDIR_P = mkdir -p
--INSTALL = install -p
--INSTALL_DATA = $(INSTALL) -m 644
--INSTALL_DIR = $(MKDIR_P) -m 755
--INSTALL_LIB = $(INSTALL_DATA)
--INSTALL_MAN = $(INSTALL_DATA)
+@@ -60,9 +60,9 @@ INSTALL = install -p
+ INSTALL_DATA = $(INSTALL) -m 644
+ INSTALL_DIR = $(MKDIR_P) -m 755
+ LIB_PERM = 644
+-INSTALL_LIB = $(INSTALL) -m $(LIB_PERM)
++INSTALL_LIB = $(BSD_INSTALL_LIB)
+ INSTALL_MAN = $(INSTALL_DATA)
-INSTALL_PROGRAM = $(INSTALL)
-+# Use ports BSD_INSTALL_PROGRAM to strip if WITH_DEBUG is not set
-+MKDIR_P = mkdir -p
-+INSTALL = install -p
-+INSTALL_DATA = ${BSD_INSTALL_DATA}
-+INSTALL_DIR = $(MKDIR_P)
-+INSTALL_LIB = ${BSD_INSTALL_LIB}
-+INSTALL_MAN = ${BSD_INSTALL_MAN}
-+INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
++INSTALL_PROGRAM = $(BSD_INSTALL_PROGRAM)
# Set by config.mk if plugins are enabled
plugindir =
-@@ -102,7 +103,7 @@ BUILT_THRASH_PROGRAMS = \
- test/thrash_threads6 \
- test/thrash_threads7
-
--all: lib-static lib-shared $(BUILT_PROGRAMS) plugins $(BUILT_TEST_PROGRAMS) \
-+all: lib-static lib-shared $(BUILT_PROGRAMS) plugins \
- htslib_static.mk htslib-uninstalled.pc
-
- ALL_CPPFLAGS = -I. $(CPPFLAGS)
diff --git a/biology/htslib/files/patch-htscodecs_htscodecs_rANS__static32x16pr__neon.c b/biology/htslib/files/patch-htscodecs_htscodecs_rANS__static32x16pr__neon.c
new file mode 100644
index 000000000000..577a3d651321
--- /dev/null
+++ b/biology/htslib/files/patch-htscodecs_htscodecs_rANS__static32x16pr__neon.c
@@ -0,0 +1,11 @@
+--- htscodecs/htscodecs/rANS_static32x16pr_neon.c.orig 2023-04-17 21:11:08 UTC
++++ htscodecs/htscodecs/rANS_static32x16pr_neon.c
+@@ -32,7 +32,7 @@
+ */
+
+ #include "config.h"
+-#ifdef __ARM_NEON
++#if defined(__ARM_NEON) && defined(__aarch64__)
+ #include <arm_neon.h>
+
+ #include <limits.h>
diff --git a/biology/htslib/files/patch-htscodecs_htscodecs_rANS__static4x16pr.c b/biology/htslib/files/patch-htscodecs_htscodecs_rANS__static4x16pr.c
new file mode 100644
index 000000000000..8f3e883eec42
--- /dev/null
+++ b/biology/htslib/files/patch-htscodecs_htscodecs_rANS__static4x16pr.c
@@ -0,0 +1,11 @@
+--- htscodecs/htscodecs/rANS_static4x16pr.c.orig 2023-04-17 21:13:50 UTC
++++ htscodecs/htscodecs/rANS_static4x16pr.c
+@@ -1006,7 +1006,7 @@ unsigned char *(*rans_dec_func(int do_simd, int order)
+ }
+ }
+
+-#elif defined(__ARM_NEON)
++#elif defined(__ARM_NEON) && defined(__aarch64__)
+
+ #if defined(__linux__) || defined(__FreeBSD__)
+ #include <sys/auxv.h>
diff --git a/biology/htslib/pkg-descr b/biology/htslib/pkg-descr
index f5684283ff81..050ad06ba93e 100644
--- a/biology/htslib/pkg-descr
+++ b/biology/htslib/pkg-descr
@@ -1,5 +1,3 @@
HTSlib is an implementation of a unified C library for accessing common file
formats, such as SAM, CRAM, VCF, and BCF, used for high-throughput sequencing
data. It is the core library used by samtools and bcftools.
-
-WWW: https://www.htslib.org/
diff --git a/biology/htslib/pkg-plist b/biology/htslib/pkg-plist
index e2ebe3a2e8d6..8c97aa84399c 100644
--- a/biology/htslib/pkg-plist
+++ b/biology/htslib/pkg-plist
@@ -34,10 +34,10 @@ lib/libhts.so
lib/libhts.so.%%PORTVERSION%%
lib/libhts.so.3
libdata/pkgconfig/htslib.pc
-man/man1/bgzip.1.gz
-man/man1/htsfile.1.gz
-man/man1/tabix.1.gz
-man/man5/faidx.5.gz
-man/man5/sam.5.gz
-man/man5/vcf.5.gz
-man/man7/htslib-s3-plugin.7.gz
+share/man/man1/bgzip.1.gz
+share/man/man1/htsfile.1.gz
+share/man/man1/tabix.1.gz
+share/man/man5/faidx.5.gz
+share/man/man5/sam.5.gz
+share/man/man5/vcf.5.gz
+share/man/man7/htslib-s3-plugin.7.gz