aboutsummaryrefslogtreecommitdiff
path: root/biology/libnuml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/libnuml/Makefile')
-rw-r--r--biology/libnuml/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/biology/libnuml/Makefile b/biology/libnuml/Makefile
new file mode 100644
index 000000000000..67dd0f9f954d
--- /dev/null
+++ b/biology/libnuml/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= libnuml
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.6
+CATEGORIES= biology devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library for Numerical Markup Language
+WWW= https://github.com/NuML/NuML
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libsbml.so:biology/libsbml
+
+USES= cmake gnome
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= NuML
+GH_PROJECT= NuML
+
+WRKSRC_SUBDIR= ${PORTNAME}
+
+post-install:
+ # no need to install LICENSE, README, VERSION
+ @${RM} -r ${STAGEDIR}${DATADIR}
+ # workaround for https://github.com/NuML/NuML/issues/26
+ ${RM} -r ${STAGEDIR}${PREFIX}/share/cmake
+
+.include <bsd.port.mk>