aboutsummaryrefslogtreecommitdiff
path: root/biology/migrate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/migrate/Makefile')
-rw-r--r--biology/migrate/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/biology/migrate/Makefile b/biology/migrate/Makefile
index c524444a06bf..fc3734ae592f 100644
--- a/biology/migrate/Makefile
+++ b/biology/migrate/Makefile
@@ -1,5 +1,5 @@
PORTNAME= migrate
-DISTVERSION= 5.0.5
+DISTVERSION= 5.0.6
CATEGORIES= biology
MASTER_SITES= https://peterbeerli.com/migrate-html5/download_version4/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -33,6 +33,10 @@ OPTIONS_DEFINE= DOCS EXAMPLES THREAD
THREAD_DESC= Build with THREAD support
THREAD_ALL_TARGET= thread
+# Upstream tarball contains objects and binaries that need to be clean
+post-extract:
+ cd ${WRKSRC} && ${RM} -f *.o haru/*.o migrate-n migrate-n-mpi
+
post-patch:
@${REINPLACE_CMD} -e 's|="-O "|="$$CFLAGS"|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/PRETTY$$/d' ${WRKSRC}/src/definitions.h