aboutsummaryrefslogtreecommitdiff
path: root/biology/py-dna-features-viewer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/py-dna-features-viewer/Makefile')
-rw-r--r--biology/py-dna-features-viewer/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/biology/py-dna-features-viewer/Makefile b/biology/py-dna-features-viewer/Makefile
new file mode 100644
index 000000000000..906de191ad5d
--- /dev/null
+++ b/biology/py-dna-features-viewer/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= dna-features-viewer
+DISTVERSION= 3.1.3
+CATEGORIES= biology python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= dna_features_viewer-${PORTVERSION}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Python library to visualize DNA features, e.g. GenBank or Gff files
+WWW= https://pypi.python.org/project/dna-features-viewer/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=3:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}biopython>0:biology/py-biopython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}bcbio-gff>0:biology/py-bcbio-gff@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>