aboutsummaryrefslogtreecommitdiff
path: root/biology/ruby-bio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/ruby-bio/Makefile')
-rw-r--r--biology/ruby-bio/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/biology/ruby-bio/Makefile b/biology/ruby-bio/Makefile
index 59f60cc2f1f6..5aa20725809e 100644
--- a/biology/ruby-bio/Makefile
+++ b/biology/ruby-bio/Makefile
@@ -1,5 +1,3 @@
-# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
-
PORTNAME= bio
PORTVERSION= 1.5.1
CATEGORIES= biology ruby
@@ -10,6 +8,7 @@ DIST_SUBDIR= ruby
MAINTAINER= mauricio@arareko.net
COMMENT= Integrated environment for Bioinformatics written in Ruby
+WWW= http://bioruby.org/
LICENSE= GPLv2 RUBY
LICENSE_COMB= dual
@@ -18,9 +17,7 @@ OPTIONS_DEFINE= BDB4 MYSQL PGSQL DOCS
BDB4_DESC= bdb4 support for faster flat file indexing
NO_ARCH= yes
-USES= shebangfix
-USE_RUBY= yes
-USE_RUBY_SETUP= yes
+USES= ruby:setup shebangfix
SHEBANG_FILES= sample/biofetch.rb
ruby_OLD_CMD= /usr/proj/bioruby/bin/ruby
@@ -28,6 +25,8 @@ BDB4_RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb.so:databases/ruby-bdb
MYSQL_RUN_DEPENDS= rubygem-dbd-mysql>=0:databases/rubygem-dbd-mysql
PGSQL_RUN_DEPENDS= rubygem-dbd-pg>=0:databases/rubygem-dbd-pg
+CONFLICTS_INSTALL= rubygem-bio-shell
+
post-patch:
${RUBY} -i -pe 'gsub(%r"(/etc/bioinformatics/)") { "${PREFIX}" + $$1 }' \
${WRKSRC}/doc/Tutorial.rd \