aboutsummaryrefslogtreecommitdiff
path: root/cad/Clipper2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/Clipper2/Makefile')
-rw-r--r--cad/Clipper2/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/cad/Clipper2/Makefile b/cad/Clipper2/Makefile
new file mode 100644
index 000000000000..6877c275f643
--- /dev/null
+++ b/cad/Clipper2/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= Clipper2
+DISTVERSION= 1.4.0
+#PORTREVISION= 1
+CATEGORIES= cad
+
+MAINTAINER= mr@freebsd.org
+COMMENT= A Polygon Clipping and Offsetting library (in C++, C# & Delphi)
+WWW= https://github.com/AngusJohnson/Clipper2
+
+LICENSE= BSL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= AngusJohnson google:gtest
+GH_PROJECT= googletest:gtest
+GH_TAGNAME= 2b665ac 71815bb:gtest
+GH_SUBDIR= CPP/Tests/googletest:gtest
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/CPP
+#CMAKE_ON=
+CMAKE_OFF= INSTALL_GTEST
+
+.include <bsd.port.mk>