aboutsummaryrefslogtreecommitdiff
path: root/cad/alliance/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/alliance/Makefile')
-rw-r--r--cad/alliance/Makefile48
1 files changed, 32 insertions, 16 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index b39afaabe8b1..c6f8ae181c25 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -1,15 +1,11 @@
-# Created by: hrs
-
PORTNAME= alliance
DISTVERSION= 5.1.1
-PORTREVISION= 2
+PORTREVISION= 6
CATEGORIES= cad
-MASTER_SITES= ftp://asim.lip6.fr/pub/alliance/distribution/5.0/ \
- ftp://ftp.lyx.org/lip6/softs/alliance/distribution/5.0/ \
- ftp://ftp.jussieu.fr/lip6/softs/alliance/distribution/5.0/
MAINTAINER= ports@FreeBSD.org
COMMENT= Complete set of CAD tools and libraries for VLSI design
+WWW= http://coriolis.lip6.fr/
LICENSE= Alliance
LICENSE_NAME= Alliance VLSI Cad System License
@@ -20,38 +16,58 @@ BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
BUILD_DEPENDS= fig2dev:print/fig2dev
-USES= autoreconf:build gmake libtool magick:build motif tar:bz2 xorg
+USE_GITLAB= yes
+GL_SITE= https://gitlab.lip6.fr
+GL_ACCOUNT= vlsi-eda
+GL_TAGNAME= ebece102e15c110fc79f1da50524c68fd9523f0c
+
+USES= autoreconf:build gmake libtool magick:build motif tar:bz2 tex xorg
USE_GCC= yes
USE_TEX= dvipsk:build latex:build
USE_XORG= ice sm x11 xext xt
HAS_CONFIGURE= yes
CONFIGURE_ENV+= ALLIANCE_TOP=${ALLIANCE_TOP} YACC=${YACC}
-CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
- --prefix=${ALLIANCE_TOP}
+CONFIGURE_ARGS+=--mandir=${PREFIX}/share/man \
+ --prefix=${ALLIANCE_TOP} \
+ --enable-alc-shared \
+ --enable-shared
+USE_LDCONFIG= ${ALLIANCE_TOP}/lib
MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
CFLAGS+= -fcommon
-CONFLICTS_INSTALL= fspclient
+CONFLICTS_INSTALL= ocp publib
SUB_FILES= pkg-message
-WRKSRC= ${WRKDIR}/alliance/src
+WRKSRC_SUBDIR= alliance/src
ALLIANCE_TOP= ${PREFIX}/alliance
-post-patch:
- @${REINPLACE_CMD} -e '/include <malloc.h>/d' \
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+pre-configure:
+ ${REINPLACE_CMD} -e '/include <malloc.h>/d' \
${WRKSRC}/xgra/src/XSB_parse.c
# Recursive make commands should always use the variable MAKE, not the
# explicit command name `make' (see the GNU make manual, section 5.7.1)
- @${REINPLACE_CMD} -e 's/; make/; $$(MAKE)/' \
+ ${REINPLACE_CMD} -e 's/; make/; $$(MAKE)/' \
${WRKSRC}/documentation/Makefile.am \
${WRKSRC}/documentation/alliance-examples/Makefile \
${WRKSRC}/documentation/tutorials/Makefile.am
+ ${RM} ${WRKSRC}/documentation/tutorials/Makefile.am.bak \
+ ${WRKSRC}/documentation/alliance-examples/Makefile.bak
+ cd ${WRKSRC} && ./autostuff
-pre-configure:
- @cd ${WRKSRC} && ./autostuff
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${ALLIANCE_TOP}/tutorials
+ (cd ${WRKSRC}/documentation/tutorials && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${ALLIANCE_TOP}/tutorials)
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${ALLIANCE_TOP}/examples
+ (cd ${WRKSRC}/documentation/alliance-examples && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${ALLIANCE_TOP}/examples)
.include <bsd.port.mk>