aboutsummaryrefslogtreecommitdiff
path: root/cad/geda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/geda/Makefile')
-rw-r--r--cad/geda/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index b67519bdc3c7..2062094db6f4 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -1,28 +1,23 @@
-# Created by: Vanilla I. Shu <vanilla@FreeBSD.org>
-
PORTNAME= geda
PORTVERSION= 1.8.2
DISTVERSIONPREFIX=gaf-
-PORTREVISION= 6
+PORTREVISION= 9
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://ftp.geda-project.org/${PORTNAME}-gaf/stable/v${PORTVERSION:R}/${PORTVERSION}/
MAINTAINER= hrs@FreeBSD.org
COMMENT= GPL Electronic Design Automation tools
+WWW= http://www.gpleda.org/
LICENSE= GPLv2+
-.if ${/usr/bin/ld:L:tA} == /usr/bin/ld.lld
-BROKEN= ld: error: ../src/.libs/libgeda.so: undefined reference to g_input_stream_get_type
-.endif
-
-LIB_DEPENDS= libstroke.so:devel/libstroke \
- libguile.so:lang/guile1
-RUN_DEPENDS= gawk:lang/gawk\
+LIB_DEPENDS= libstroke.so:devel/libstroke
+RUN_DEPENDS= gawk:lang/gawk
-USES= desktop-file-utils gettext gmake gnome libtool pathfix perl5 \
- pkgconfig python:run shared-mime-info shebangfix
+USES= desktop-file-utils gettext gmake gnome guile:1.8 libtool \
+ pathfix perl5 pkgconfig python:run shared-mime-info \
+ shebangfix
SHEBANG_FILES= examples/lightning_detector/bom libgeda/docs/*.dox \
utils/gxyrs/*.pl utils/scripts/* \
utils/docs/*.dox gattrib/docs/*.dox \
@@ -32,19 +27,17 @@ USE_GNOME= gtk20
USE_PERL5= run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libstroke=${LOCALBASE}
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-gaf
DATADIR= ${PREFIX}/share/gEDA
INFO= geda-scheme
BINARY_WRAPPERS= gm4
-CONFLICTS= geda-docs-[0-9]* geda-examples-[0-9]* geda-gattrib-[0-9]* \
- geda-gschem-[0-9]* geda-netlist-[0-9]* geda-symbols-[0-9]* \
- geda-symcheck-[0-9]* geda-utils-[0-9]* libgeda-[0-9]*
+CONFLICTS= geda-docs geda-examples geda-gattrib \
+ geda-gschem geda-netlist geda-symbols \
+ geda-symcheck geda-utils libgeda
PORTSCOUT= limitw:1,even