aboutsummaryrefslogtreecommitdiff
path: root/cad/opentimer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/opentimer/Makefile')
-rw-r--r--cad/opentimer/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/cad/opentimer/Makefile b/cad/opentimer/Makefile
new file mode 100644
index 000000000000..53265f808609
--- /dev/null
+++ b/cad/opentimer/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= opentimer
+PORTVERSION= g20221116
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High-performance timing analysis tool for VLSI systems
+WWW= https://github.com/OpenTimer/OpenTimer
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BROKEN_i386= undefined reference to `__atomic_compare_exchange_8' #'`
+BROKEN_powerpc= undefined reference to `__atomic_compare_exchange_8' #'`
+
+USES= cmake compiler:c++17-lang python:test shebangfix tcl
+
+SHEBANG_FILES= inttest/*.py
+
+USE_GITHUB= yes
+GH_ACCOUNT= OpenTimer
+GH_PROJECT= OpenTimer
+GH_TAGNAME= a57d03b
+
+TEST_TARGET= test
+
+PLIST_FILES= bin/ot-shell \
+ bin/ot-tau15 \
+ bin/ot-tau18 \
+ bin/ot-utility
+
+do-install: # see https://github.com/OpenTimer/OpenTimer/issues/47
+.for e in ot-shell ot-tau15 ot-tau18 ot-utility
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${e} ${STAGEDIR}${PREFIX}/bin
+.endfor
+
+quick-test: # runs the script suggested in https://github.com/OpenTimer/OpenTimer
+ @cd ${WRKSRC} && \
+ bin/ot-shell < ${FILESDIR}/test.txt
+
+.include <bsd.port.mk>