aboutsummaryrefslogtreecommitdiff
path: root/cad/xyce
diff options
context:
space:
mode:
Diffstat (limited to 'cad/xyce')
-rw-r--r--cad/xyce/Makefile76
-rw-r--r--cad/xyce/distinfo3
-rw-r--r--cad/xyce/pkg-descr8
-rw-r--r--cad/xyce/pkg-plist97
4 files changed, 184 insertions, 0 deletions
diff --git a/cad/xyce/Makefile b/cad/xyce/Makefile
new file mode 100644
index 000000000000..7ba15d45ac1d
--- /dev/null
+++ b/cad/xyce/Makefile
@@ -0,0 +1,76 @@
+PORTNAME= xyce
+DISTVERSIONPREFIX= Release-
+DISTVERSION= 7.8.0
+PORTREVISION= 4
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Xyce electronic simulator
+WWW= https://xyce.sandia.gov/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libblas.so:math/blas \
+ libfftw3.so:math/fftw3 \
+ liblapack.so:math/lapack \
+ libtpetra.so:science/trilinos \
+ \
+ libamd.so:math/suitesparse-amd \
+ libcholmod.so:math/suitesparse-cholmod \
+ libcolamd.so:math/suitesparse-colamd \
+ libsuitesparseconfig.so:math/suitesparse-config \
+ libumfpack.so:math/suitesparse-umfpack
+TEST_DEPENDS= git:devel/git \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= autoreconf bison gmake fortran libtool localbase perl5 python:test # GNU tools should be used for 7.5 and on until the cmake build is declared stable
+USE_CXXSTD= c++14 # otherwise configure fails because of c++14 features like std::conditional_t
+USE_CXXSTD= c++17 # workaround for https://github.com/Xyce/Xyce/issues/97, which occurred when Trilinos was updated to 15.1.0
+USE_LDCONFIG= yes
+USE_PERL5= test
+
+USE_GITHUB= yes
+GH_ACCOUNT= Xyce
+GH_PROJECT= Xyce
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= LEX=/usr/bin/flex \
+ --enable-stokhos \
+ --enable-amesos \
+ --enable-shared \
+ --disable-static
+
+INSTALL_TARGET= install-strip
+
+BINARY_ALIAS= python=${PYTHON_CMD} # only for tests
+
+do-test: # one test is known to fail, see https://github.com/Xyce/Xyce/issues/67#issuecomment-1179857728
+ # checkout tests
+ @cd ${WRKDIR} && \
+ ${ECHO} "cloning git repository ..." && \
+ ${RM} -rf Xyce_Regression && \
+ git clone -q https://github.com/Xyce/Xyce_Regression.git && \
+ cd Xyce_Regression && \
+ git checkout -q Release-${DISTVERSION}
+
+ # run tests
+ @cd ${TEST_WRKSRC} && ( \
+ ${ECHO} "running tests ..."; \
+ eval `${WRKDIR}/Xyce_Regression/TestScripts/suggestXyceTagList.sh ${STAGEDIR}${PREFIX}/bin/Xyce` ; \
+ ${SETENV} ${TEST_ENV} ${WRKDIR}/Xyce_Regression/TestScripts/run_xyce_regression \
+ --output=${WRKDIR}/Xyce_Test \
+ --xyce_test="${WRKDIR}/Xyce_Regression" \
+ --resultfile=${WRKDIR}/serial_results \
+ --taglist="$$TAGLIST" \
+ ${STAGEDIR}${PREFIX}/bin/Xyce \
+ )
+ # Testssuite doesn't stop when Ctrl-C is pressed: https://github.com/Xyce/Xyce_Regression/issues/1
+
+# Trilinos build instructions for Xyce: https://xyce.sandia.gov/documentation-tutorials/building-guide/#instTrilinos
+# Xyce build instructions: https://xyce.sandia.gov/documentation-tutorials/building-guide/
+# Xyce regression suite instructions: https://xyce.sandia.gov/documentation-tutorials/running-the-xyce-regression-suite/
+# docs are in https://xyce.sandia.gov/files/xyce/Xyce_Docs-7.5.tar.gz
+
+.include <bsd.port.mk>
diff --git a/cad/xyce/distinfo b/cad/xyce/distinfo
new file mode 100644
index 000000000000..da99693e914a
--- /dev/null
+++ b/cad/xyce/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1702614493
+SHA256 (Xyce-Xyce-Release-7.8.0_GH0.tar.gz) = f763b7d5ad6defd25d2c7e5cc95155958cd12510a5e22a179daab459b21fa713
+SIZE (Xyce-Xyce-Release-7.8.0_GH0.tar.gz) = 23405203
diff --git a/cad/xyce/pkg-descr b/cad/xyce/pkg-descr
new file mode 100644
index 000000000000..d7c0dd68e179
--- /dev/null
+++ b/cad/xyce/pkg-descr
@@ -0,0 +1,8 @@
+Xyce (zis, rhymes with "spice") is an open source,
+SPICE-compatible, high-performance analog circuit simulator, capable
+of solving extremely large circuit problems by supporting large-scale
+parallel computing platforms. It also supports serial execution on all
+common desktop platforms, and small-scale parallel runs on Unix-like
+systems. In addition to analog electronic simulation, Xyce has also
+been used to investigate more general network systems, such as neural
+networks and power grids. Read more about Xyce.
diff --git a/cad/xyce/pkg-plist b/cad/xyce/pkg-plist
new file mode 100644
index 000000000000..2f8ee5043571
--- /dev/null
+++ b/cad/xyce/pkg-plist
@@ -0,0 +1,97 @@
+bin/Xyce
+include/N_ANP_NoiseData.h
+include/N_ANP_fwd.h
+include/N_CIR_GenCouplingSimulator.h
+include/N_CIR_Xyce.h
+include/N_DEV_ADC.h
+include/N_DEV_BJT.h
+include/N_DEV_Capacitor.h
+include/N_DEV_Configuration.h
+include/N_DEV_Const.h
+include/N_DEV_DAC.h
+include/N_DEV_Depend.h
+include/N_DEV_Device.h
+include/N_DEV_DeviceBlock.h
+include/N_DEV_DeviceEntity.h
+include/N_DEV_DeviceInstance.h
+include/N_DEV_DeviceMaster.h
+include/N_DEV_DeviceModel.h
+include/N_DEV_DeviceOptions.h
+include/N_DEV_DeviceSupport.h
+include/N_DEV_Diode.h
+include/N_DEV_ExternData.h
+include/N_DEV_ExternalSimulationData.h
+include/N_DEV_InstanceName.h
+include/N_DEV_JFET.h
+include/N_DEV_MOSFET1.h
+include/N_DEV_Message.h
+include/N_DEV_Param.h
+include/N_DEV_Pars.h
+include/N_DEV_Resistor.h
+include/N_DEV_SolverState.h
+include/N_DEV_Units.h
+include/N_DEV_VectorComputeInterface.h
+include/N_DEV_fwd.h
+include/N_ERH_Message.h
+include/N_ERH_fwd.h
+include/N_IO_CmdParse.h
+include/N_IO_ExtOutInterface.h
+include/N_IO_HangingResistor.h
+include/N_IO_OutputTypes.h
+include/N_IO_fwd.h
+include/N_LAS_Matrix.h
+include/N_LAS_MultiVector.h
+include/N_LAS_Vector.h
+include/N_LAS_fwd.h
+include/N_LOA_Loader.h
+include/N_LOA_fwd.h
+include/N_NLS_TwoLevelEnum.h
+include/N_NLS_fwd.h
+include/N_PDS_MPI.h
+include/N_PDS_Manager.h
+include/N_PDS_ParallelMachine.h
+include/N_PDS_Serial.h
+include/N_PDS_fwd.h
+include/N_TIA_TwoLevelError.h
+include/N_TIA_fwd.h
+include/N_TOP_fwd.h
+include/N_UTL_BreakPoint.h
+include/N_UTL_Diagnostic.h
+include/N_UTL_Expression.h
+include/N_UTL_ExpressionData.h
+include/N_UTL_ExpressionSymbolTable.h
+include/N_UTL_FeatureTest.h
+include/N_UTL_FormatTime.h
+include/N_UTL_Interface_Enum_Types.h
+include/N_UTL_JSON.h
+include/N_UTL_MachDepParams.h
+include/N_UTL_Marshal.h
+include/N_UTL_Math.h
+include/N_UTL_Misc.h
+include/N_UTL_NameLevelKey.h
+include/N_UTL_NetlistLocation.h
+include/N_UTL_NoCase.h
+include/N_UTL_NodeSymbols.h
+include/N_UTL_Op.h
+include/N_UTL_Pack.h
+include/N_UTL_Param.h
+include/N_UTL_ReportHandler.h
+include/N_UTL_StatMetricTraits.h
+include/N_UTL_Stats.h
+include/N_UTL_TypeIndex.h
+include/N_UTL_Xyce.h
+include/N_UTL_fwd.h
+include/Xyce_config.h
+lib/libxyce.so
+lib/libxyce.so.0
+lib/libxyce.so.0.0.0
+share/xml/adms.implicit.xml
+share/xml/html_params.xml
+share/xml/xyceAnalogFunction_nosac.xml
+share/xml/xyceBasicTemplates_nosac.xml
+share/xml/xyceBootstrapFile.xml
+share/xml/xyceHeaderFile_nosac.xml
+share/xml/xyceImplementationFile_nosac.xml
+share/xml/xyceMakefile.am.xml
+share/xml/xyceOutVarsDoc.xml
+share/xml/xyceVersion_nosac.xml