aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-rime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/fcitx5-rime/Makefile')
-rw-r--r--chinese/fcitx5-rime/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/chinese/fcitx5-rime/Makefile b/chinese/fcitx5-rime/Makefile
index 5a9f4d2429dc..f774a50ec0d5 100644
--- a/chinese/fcitx5-rime/Makefile
+++ b/chinese/fcitx5-rime/Makefile
@@ -1,7 +1,7 @@
PORTNAME= fcitx5-rime
-DISTVERSION= 5.0.8
-PORTREVISION= 1
+DISTVERSION= 5.0.16
CATEGORIES= chinese textproc
+MASTER_SITES= https://download.fcitx-im.org/fcitx5/${PORTNAME}/
MAINTAINER= khng@FreeBSD.org
COMMENT= RIME support for Fcitx5
@@ -11,24 +11,21 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
BUILD_DEPENDS= ${_SCHEMA_DEPENDS}
-LIB_DEPENDS= librime.so:chinese/librime \
- libFcitx5Core.so:textproc/fcitx5
+LIB_DEPENDS= libFcitx5Core.so:textproc/fcitx5 \
+ librime.so:chinese/librime
RUN_DEPENDS= ${_SCHEMA_DEPENDS}
-USES= compiler:c++17-lang gettext-tools cmake kde:5 localbase \
- pkgconfig
-
-USE_GITHUB= yes
-GH_ACCOUNT= fcitx
+USES= cmake compiler:c++17-lang gettext-tools kde:5 localbase \
+ pkgconfig tar:xz
USE_KDE= ecm
CONFLICTS_INSTALL= zh-fcitx-rime # share/icons/hicolor/48x48/apps/fcitx-rime-deploy.png
_SCHEMA_DEPENDS= \
- ${LOCALBASE}/share/rime-data/luna_pinyin.schema.yaml:chinese/rime-luna-pinyin \
${LOCALBASE}/share/rime-data/bopomofo.schema.yaml:chinese/rime-bopomofo \
${LOCALBASE}/share/rime-data/cangjie5.schema.yaml:chinese/rime-cangjie \
+ ${LOCALBASE}/share/rime-data/luna_pinyin.schema.yaml:chinese/rime-luna-pinyin \
${LOCALBASE}/share/rime-data/stroke.schema.yaml:chinese/rime-stroke
.include <bsd.port.mk>