aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/gammu/Makefile')
-rw-r--r--comms/gammu/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 09920f5b9af2..9ee0c0b21c8e 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -19,7 +19,7 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:259:env
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PORTDOCS= *
@@ -28,6 +28,10 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -fPIC"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= does not compile with gcc 2.95
+.endif
+
post-patch:
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|%zd|%d|g' -e 's|%zi|%i|g' \