aboutsummaryrefslogtreecommitdiff
path: root/comms/gqrx
diff options
context:
space:
mode:
Diffstat (limited to 'comms/gqrx')
-rw-r--r--comms/gqrx/Makefile33
-rw-r--r--comms/gqrx/distinfo6
-rw-r--r--comms/gqrx/pkg-descr2
3 files changed, 26 insertions, 15 deletions
diff --git a/comms/gqrx/Makefile b/comms/gqrx/Makefile
index 1798b726fb51..1a5029f2fa69 100644
--- a/comms/gqrx/Makefile
+++ b/comms/gqrx/Makefile
@@ -1,13 +1,13 @@
-# Created by: Ganael Laplanche <ganael.laplanche@martymac.org>
-
PORTNAME= gqrx
-PORTVERSION= 2.15.2
+PORTVERSION= 2.17.4
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= comms hamradio
+PKGNAMESUFFIX= -${FLAVOR}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Software defined radio receiver powered by GNU Radio and Qt
+WWW= https://gqrx.dk
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -32,26 +32,39 @@ LIB_DEPENDS= libgnuradio-runtime.so:comms/gnuradio \
libjack.so:audio/jack \
libportaudio.so:audio/portaudio
-USES= cmake compiler:c++11-lang gl pkgconfig qt:5
+FLAVORS= qt6 qt5
+FLAVOR?= qt6
+
+USES= cmake compiler:c++11-lang gl pkgconfig qt:${FLAVOR:S/qt//}
USE_GITHUB= yes
GH_ACCOUNT= gqrx-sdr
USE_GL= gl
-USE_QT= core gui network svg widgets
+_USE_QT_qt5= core gui network svg widgets
+_USE_QT_qt6= base svg
+USE_QT= ${_USE_QT_${FLAVOR}}
+
+CONFLICTS_INSTALL= gqrx ${FLAVORS:N${FLAVOR}:S/^/${PORTNAME}-/}
# XXX Use Portaudio as Gqrx is invariably linked to it
# (auto-detected and used through Gnuradio CMake files)
-CMAKE_ARGS+= -DLINUX_AUDIO_BACKEND:STRING="Portaudio"
+CMAKE_ARGS+= -DLINUX_AUDIO_BACKEND:STRING="Portaudio" \
+ -DFORCE_QT${FLAVOR:S/qt//}:BOOL=ON
+
+# XXX Work around Gnuradio 3.8 headers (gnuradio/rpcserver_aggregator.h) still
+# using std::unary_function (removed with C++17). This breaks when building
+# on FreeBSD 14: error: no template named 'unary_function' in namespace 'std'
+CXXFLAGS+= -D_LIBCPP_ENABLE_CXX17_REMOVED_UNARY_BINARY_FUNCTION
PLIST_FILES= bin/gqrx \
- share/applications/gqrx.desktop \
- man/man1/gqrx.1.gz
+ share/applications/dk.gqrx.gqrx.desktop \
+ share/man/man1/gqrx.1.gz
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/src/gqrx ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/gqrx.desktop \
+ ${INSTALL_DATA} ${WRKSRC}/dk.gqrx.gqrx.desktop \
${STAGEDIR}${PREFIX}/share/applications
${INSTALL_MAN} ${WRKSRC}/resources/gqrx.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1
+ ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/comms/gqrx/distinfo b/comms/gqrx/distinfo
index 2462ce4bca9a..6a806e68a256 100644
--- a/comms/gqrx/distinfo
+++ b/comms/gqrx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1641839644
-SHA256 (gqrx-sdr-gqrx-v2.15.2_GH0.tar.gz) = c4fc85e6aec257e56e0c2963c5c2f7aa210a8b6df73f7cb4e398ec2f1c9e1d33
-SIZE (gqrx-sdr-gqrx-v2.15.2_GH0.tar.gz) = 1348120
+TIMESTAMP = 1707772014
+SHA256 (gqrx-sdr-gqrx-v2.17.4_GH0.tar.gz) = 06be55cd8ccadd3cb08218a4234f94c5c2bcd9e7b63a775650e473115e93d4e7
+SIZE (gqrx-sdr-gqrx-v2.17.4_GH0.tar.gz) = 3623122
diff --git a/comms/gqrx/pkg-descr b/comms/gqrx/pkg-descr
index d0f9d2dc31c6..e8338ef55b24 100644
--- a/comms/gqrx/pkg-descr
+++ b/comms/gqrx/pkg-descr
@@ -13,5 +13,3 @@ Radio and the Qt GUI toolkit. Currently it supports the following devices:
Gqrx can operate as a traditional AM/FM/SSB receiver with audio output or as
an FFT-only instrument.
-
-WWW: http://gqrx.dk