aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile121
1 files changed, 0 insertions, 121 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
deleted file mode 100644
index 7811c523d8c5..000000000000
--- a/comms/hylafax/Makefile
+++ /dev/null
@@ -1,121 +0,0 @@
-PORTNAME= hylafax
-PORTVERSION= 6.0.7
-PORTREVISION= 1
-CATEGORIES= comms
-MASTER_SITES= ftp://ftp.hylafax.org/source/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fax software
-WWW= https://www.hylafax.org/
-
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:print/afm
-LIB_DEPENDS= libtiff.so:graphics/tiff \
- libjbig.so:graphics/jbigkit
-
-USES= cpe fakeroot ghostscript jpeg
-
-USE_RC_SUBR= hylafax
-
-MAKE_JOBS_UNSAFE= yes
-HAS_CONFIGURE= yes
-
-DEPRECATED= dead upstream, someone port hylafax+ from sourceforge.net instead
-EXPIRATION_DATE=2022-09-30
-
-CONFIGURE_ARGS= --with-INSTALL="" \
- --with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
- --with-ZLIB=no --with-LIBZ=-lz \
- --with-TIFFINC="-I${LOCALBASE}/include" \
- --with-GCOPTS=" " --with-GCXXOPTS=" " \
- --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=-I/usr/include \
- --with-DIR_HTML="${DOCSDIR}" \
- --with-GETTY=SysV
-CFLAGS+= -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -Wall -L${LOCALBASE}/lib
-CONFIGURE_ENV= ENVOPTS="${CFLAGS}" STRIP=/usr/bin/true
-MAKE_ENV+= ROOT=${STAGEDIR}
-MAKE_ARGS+= OPTIMIZER="" -DOPTIMIZER
-
-CONFLICTS_INSTALL= mgetty
-
-PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt RELEASENOTES-6.0.txt
-SUB_FILES= pkg-message
-
-OPTIONS_DEFINE= PAM NLS GAWK DOCS
-OPTIONS_DEFAULT=PAM
-OPTIONS_SUB= yes
-
-NO_OPTIONS_SORT=yes
-
-GAWK_DESC= Use gawk for scripts
-
-PAM_CONFIGURE_OFF= --disable-pam
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-
-GAWK_BUILD_DEPENDS= gawk:lang/gawk
-GAWK_RUN_DEPENDS= gawk:lang/gawk
-GAWK_CONFIGURE_ON= --with-AWK="${LOCALBASE}/bin/gawk"
-
-DOCS_CONFIGURE_ON= --with-HTML=yes
-
-.include <bsd.port.options.mk>
-
-# Defaults to "North American Letter". Use "ISO A4" for A4.
-.if defined(PAGESIZE)
-CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
-.endif
-
-# Redefine path for spool
-.if defined(HYLAFAX_SPOOL)
-CONFIGURE_ARGS+=--with-DIR_SPOOL="${HYLAFAX_SPOOL}"
-.endif
-HYLAFAX_SPOOL?= /var/spool/hylafax
-PLIST_SUB+= HYLAFAX_SPOOL=${HYLAFAX_SPOOL}
-
-.if defined(PACKAGE_BUILDING) || defined(BATCH)
-CONFIGURE_ARGS+=--nointeractive
-.endif
-
-post-patch:
- ${REINPLACE_CMD} \
- -e 's,/usr/local,${LOCALBASE},g' \
- -e 's,-ljbig,-L${LOCALBASE}/lib &,' \
- ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's,-O hfaxd.conf,-O hfaxd.conf.sample,' \
- ${WRKSRC}/hfaxd/Makefile.in
- ${REINPLACE_CMD} -e 's,hosts.hfaxd,hosts.hfaxd.sample,' \
- ${WRKSRC}/etc/Makefile.in
- ${REINPLACE_CMD} -e 's,-O typerules,-O typerules.sample,' \
- -e 's,-O pagesizes,-O pagesizes.sample -src pagesizes,' \
- ${WRKSRC}/libhylafax/Makefile.in
-
-pre-install:
- ${MKDIR} ${STAGEDIR}${HYLAFAX_SPOOL}/archive \
- ${STAGEDIR}${HYLAFAX_SPOOL}/docq \
- ${STAGEDIR}${HYLAFAX_SPOOL}/doneq \
- ${STAGEDIR}${HYLAFAX_SPOOL}/pollq \
- ${STAGEDIR}${HYLAFAX_SPOOL}/sendq \
- ${STAGEDIR}${HYLAFAX_SPOOL}/tmp \
- ${STAGEDIR}${HYLAFAX_SPOOL}/info \
- ${STAGEDIR}${HYLAFAX_SPOOL}/log
-
-post-install:
-.for i in bin/faxalter bin/faxcover bin/faxmail bin/faxrm bin/faxstat bin/sendfax \
-bin/sendpage sbin/choptest sbin/cqtest sbin/dialtest sbin/faxabort \
-sbin/faxadduser sbin/faxanswer sbin/faxconfig sbin/faxdeluser \
-sbin/faxgetty sbin/faxinfo sbin/faxlock sbin/faxmodem sbin/faxmsg \
-sbin/faxq sbin/faxqclean sbin/faxquit sbin/faxsend sbin/faxstate \
-sbin/faxwatch sbin/hfaxd sbin/lockname sbin/ondelay sbin/pagesend \
-sbin/tagtest sbin/textfmt sbin/tiffcheck sbin/tsitest sbin/typetest
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${i}
-.endfor
-
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
-
-.include <bsd.port.mk>