aboutsummaryrefslogtreecommitdiff
path: root/comms/librs232/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/librs232/Makefile')
-rw-r--r--comms/librs232/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/comms/librs232/Makefile b/comms/librs232/Makefile
index 9a650748197b..de950269b672 100644
--- a/comms/librs232/Makefile
+++ b/comms/librs232/Makefile
@@ -4,27 +4,38 @@ CATEGORIES= comms
DISTNAME= RS-232
MASTER_SITES= http://www.teuniz.net/RS-232/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Simple serial library
+WWW= https://www.teuniz.net/RS-232/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/gpl.txt
+LICENSE_FILE= ${WRKSRC}/gpl.txt
+
+USES= uidfix
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
+PORTEXAMPLES= demo_rx.c demo_tx.c
+
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= uidfix
-USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
-PORTEXAMPLES= demo_rx.c demo_tx.c
+.if defined(NO_PROFILE) || ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079 )
+PLIST_SUB+= PROFILE="@comment "
+.else
+PLIST_SUB+= PROFILE=""
+.endif
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc.txt ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${PORTEXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${EXAMPLESDIR}