aboutsummaryrefslogtreecommitdiff
path: root/comms/limesuite/files/patch-Desktop_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'comms/limesuite/files/patch-Desktop_CMakeLists.txt')
-rw-r--r--comms/limesuite/files/patch-Desktop_CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/comms/limesuite/files/patch-Desktop_CMakeLists.txt b/comms/limesuite/files/patch-Desktop_CMakeLists.txt
deleted file mode 100644
index c1a8629431ce..000000000000
--- a/comms/limesuite/files/patch-Desktop_CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
---- Desktop/CMakeLists.txt.orig 2020-10-29 09:52:56 UTC
-+++ Desktop/CMakeLists.txt
-@@ -1,13 +1,13 @@
- ########################################################################
- ## Feature registration
- ########################################################################
--if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
-- set(LINUX TRUE)
-+if(CMAKE_SYSTEM_NAME STREQUAL "Linux" OR "FreeBSD")
-+ set(UNIX TRUE)
- endif()
-
- include(FeatureSummary)
- include(CMakeDependentOption)
--cmake_dependent_option(ENABLE_DESKTOP "Enable LimeSuite launcher and icons" ON "ENABLE_GUI;LINUX" OFF)
-+cmake_dependent_option(ENABLE_DESKTOP "Enable LimeSuite launcher and icons" ON "ENABLE_GUI;UNIX" OFF)
- add_feature_info(LimeSuiteDesktop ENABLE_DESKTOP "LimeSuite freedesktop integration")
- if (NOT ENABLE_DESKTOP)
- return()