aboutsummaryrefslogtreecommitdiff
path: root/comms/spandsp-devel
diff options
context:
space:
mode:
Diffstat (limited to 'comms/spandsp-devel')
-rw-r--r--comms/spandsp-devel/Makefile40
-rw-r--r--comms/spandsp-devel/distinfo3
-rw-r--r--comms/spandsp-devel/files/patch-src-Makefile.in11
-rw-r--r--comms/spandsp-devel/files/patch-src-playout.c10
-rw-r--r--comms/spandsp-devel/files/patch-src-power_meter.c13
-rw-r--r--comms/spandsp-devel/files/patch-src-spandsp-dc_restore.h14
-rw-r--r--comms/spandsp-devel/files/patch-src-t31.c28
-rw-r--r--comms/spandsp-devel/pkg-descr4
-rw-r--r--comms/spandsp-devel/pkg-plist60
9 files changed, 0 insertions, 183 deletions
diff --git a/comms/spandsp-devel/Makefile b/comms/spandsp-devel/Makefile
deleted file mode 100644
index e71e33ed53a1..000000000000
--- a/comms/spandsp-devel/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# New ports collection makefile for: spandsp
-# Date created: 23 June 2005
-# Whom: wlloyd@slap.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= spandsp
-DISTVERSION= 0.0.2pre20
-PORTREVISION= 1
-CATEGORIES= comms
-MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/${PORTNAME}-${DISTVERSION}/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= pav
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fax DSP library for Asterisk
-
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/pre.*$//}
-
-USE_GMAKE= yes
-USE_REINPLACE= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-INSTALLS_SHLIB= yes
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${FIND} ${WRKSRC} -name *.c | ${XARGS} ${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|'
-.if ${OSVERSION} < 503000
- ${TOUCH} ${WRKSRC}/src/tgmath.h
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/comms/spandsp-devel/distinfo b/comms/spandsp-devel/distinfo
deleted file mode 100644
index e6c26c8b079e..000000000000
--- a/comms/spandsp-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (spandsp-0.0.2pre20.tar.gz) = 8d6e94a30fb4698b5f25eb93e26444e1
-SHA256 (spandsp-0.0.2pre20.tar.gz) = 8523c1a4da13e11c5096213e434bc69d96ea65cddde27b5b7fc83bf52787b7ef
-SIZE (spandsp-0.0.2pre20.tar.gz) = 1312403
diff --git a/comms/spandsp-devel/files/patch-src-Makefile.in b/comms/spandsp-devel/files/patch-src-Makefile.in
deleted file mode 100644
index 3b8f9a6f252d..000000000000
--- a/comms/spandsp-devel/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in~ Thu Apr 28 09:03:02 2005
-+++ src/Makefile.in Thu Jun 23 15:27:14 2005
-@@ -211,7 +211,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- MAINTAINERCLEANFILES = Makefile.in
--INCLUDES = -I$(top_buildir)
-+#INCLUDES = -I$(top_buildir)
- lib_LTLIBRARIES = libspandsp.la
- libspandsp_la_SOURCES = adsi.c \
- awgn.c \
diff --git a/comms/spandsp-devel/files/patch-src-playout.c b/comms/spandsp-devel/files/patch-src-playout.c
deleted file mode 100644
index 2674f62f0de3..000000000000
--- a/comms/spandsp-devel/files/patch-src-playout.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/playout.c~ Fri Feb 4 14:19:30 2005
-+++ src/playout.c Thu Jun 23 15:35:06 2005
-@@ -37,6 +37,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <limits.h>
-+#include <sys/types.h>
-
- #include "spandsp/telephony.h"
- #include "spandsp/playout.h"
diff --git a/comms/spandsp-devel/files/patch-src-power_meter.c b/comms/spandsp-devel/files/patch-src-power_meter.c
deleted file mode 100644
index 5209632685e7..000000000000
--- a/comms/spandsp-devel/files/patch-src-power_meter.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/power_meter.c.orig Thu Jun 30 22:40:33 2005
-+++ src/power_meter.c Thu Jun 30 22:41:05 2005
-@@ -72,6 +72,10 @@
- }
- /*- End of function --------------------------------------------------------*/
-
-+#ifndef INFINITY
-+#define INFINITY (float)HUGE_VAL
-+#endif
-+
- float power_meter_dbm0(power_meter_t *meter)
- {
- float val;
diff --git a/comms/spandsp-devel/files/patch-src-spandsp-dc_restore.h b/comms/spandsp-devel/files/patch-src-spandsp-dc_restore.h
deleted file mode 100644
index d2f63ad0d8e4..000000000000
--- a/comms/spandsp-devel/files/patch-src-spandsp-dc_restore.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/spandsp/dc_restore.h.orig Tue Jan 18 15:05:48 2005
-+++ src/spandsp/dc_restore.h Thu Jun 30 22:35:33 2005
-@@ -85,6 +85,11 @@
- }
- /*- End of function --------------------------------------------------------*/
-
-+#ifndef INT16_MAX
-+#define INT16_MAX 0x7fff
-+#define INT16_MIN (-0x7fff-1)
-+#endif
-+
- static inline int16_t saturate(int32_t amp)
- {
- if (amp > INT16_MAX)
diff --git a/comms/spandsp-devel/files/patch-src-t31.c b/comms/spandsp-devel/files/patch-src-t31.c
deleted file mode 100644
index 7ffd6abfd2d6..000000000000
--- a/comms/spandsp-devel/files/patch-src-t31.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/t31.c.orig Thu Jun 30 23:07:14 2005
-+++ src/t31.c Thu Jun 30 23:10:28 2005
-@@ -51,19 +51,12 @@
- t31_profile_t profiles[3] =
- {
- {
-- .echo = TRUE,
-- .verbose = TRUE,
-- .result_code_format = ASCII_RESULT_CODES,
-- .pulse_dial = FALSE,
-- .double_escape = FALSE,
-- .s_regs[0] = 0,
-- .s_regs[3] = '\r',
-- .s_regs[4] = '\n',
-- .s_regs[5] = '\b',
-- .s_regs[6] = 1,
-- .s_regs[7] = 60,
-- .s_regs[8] = 5,
-- .s_regs[10] = 0
-+ TRUE,
-+ TRUE,
-+ ASCII_RESULT_CODES,
-+ FALSE,
-+ FALSE,
-+ { 0, 0, 0, '\r', '\n', '\b', 1, 60, 5, 0 }
- }
- };
-
diff --git a/comms/spandsp-devel/pkg-descr b/comms/spandsp-devel/pkg-descr
deleted file mode 100644
index a19fea158bbc..000000000000
--- a/comms/spandsp-devel/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Spandsp is a DSP library to support fax functions in the Asterisk PBX.
-Basically it implements a software fax machine to fax out or in.
-
-WWW: http://www.soft-switch.org/
diff --git a/comms/spandsp-devel/pkg-plist b/comms/spandsp-devel/pkg-plist
deleted file mode 100644
index 003fe92936d0..000000000000
--- a/comms/spandsp-devel/pkg-plist
+++ /dev/null
@@ -1,60 +0,0 @@
-include/spandsp.h
-include/spandsp/adsi.h
-include/spandsp/alaw_ulaw.h
-include/spandsp/arctan2.h
-include/spandsp/awgn.h
-include/spandsp/bert.h
-include/spandsp/biquad.h
-include/spandsp/complex.h
-include/spandsp/complex_filters.h
-include/spandsp/dc_restore.h
-include/spandsp/dds.h
-include/spandsp/ec_disable_detector.h
-include/spandsp/echo.h
-include/spandsp/fir.h
-include/spandsp/fsk.h
-include/spandsp/g168models.h
-include/spandsp/hdlc.h
-include/spandsp/ima_adpcm.h
-include/spandsp/logging.h
-include/spandsp/mmx.h
-include/spandsp/modem_echo.h
-include/spandsp/oki_adpcm.h
-include/spandsp/oss.h
-include/spandsp/playout.h
-include/spandsp/plc.h
-include/spandsp/power_meter.h
-include/spandsp/queue.h
-include/spandsp/schedule.h
-include/spandsp/sig_tone.h
-include/spandsp/super_tone_rx.h
-include/spandsp/super_tone_tx.h
-include/spandsp/t30.h
-include/spandsp/t30_fcf.h
-include/spandsp/t31.h
-include/spandsp/t35.h
-include/spandsp/t4.h
-include/spandsp/telephony.h
-include/spandsp/time_scale.h
-include/spandsp/timing.h
-include/spandsp/tone_detect.h
-include/spandsp/tone_generate.h
-include/spandsp/v17rx.h
-include/spandsp/v17tx.h
-include/spandsp/v22bis.h
-include/spandsp/v27ter_rx.h
-include/spandsp/v27ter_tx.h
-include/spandsp/v29rx.h
-include/spandsp/v29tx.h
-include/spandsp/v42.h
-include/spandsp/v42bis.h
-include/spandsp/v8.h
-include/spandsp/vector.h
-lib/libspandsp.a
-lib/libspandsp.la
-lib/libspandsp.so
-lib/libspandsp.so.0
-%%DATADIR%%/global-tones.xml
-%%DATADIR%%/tones.dtd
-@dirrm %%DATADIR%%
-@dirrm include/spandsp