aboutsummaryrefslogtreecommitdiff
path: root/converters/o3read/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/o3read/Makefile')
-rw-r--r--converters/o3read/Makefile24
1 files changed, 7 insertions, 17 deletions
diff --git a/converters/o3read/Makefile b/converters/o3read/Makefile
index 70d852bb908f..3173bf24fafb 100644
--- a/converters/o3read/Makefile
+++ b/converters/o3read/Makefile
@@ -11,27 +11,17 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= samm@os2.kiev.ua
COMMENT= Standalone converter for the OpenOffice.org writer and scalc formats
-MAN1= o3read.1 utf8tolatin1.1
-MLINKS= o3read.1 o3totxt.1 o3read.1 o3tohtml.1
PORTDOCS= README COPYING ChangeLog
-PLIST_FILES= bin/o3read bin/o3totxt bin/o3tohtml bin/utf8tolatin1
-
-NO_STAGE= yes
-
-.include <bsd.port.options.mk>
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/o3read ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/o3totxt ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/o3tohtml ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/utf8tolatin1 ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/o3read.1 ${MANPREFIX}/man/man1
- @${INSTALL_MAN} ${WRKSRC}/utf8tolatin1.1 ${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/o3read ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/o3totxt ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/o3tohtml ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/utf8tolatin1 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>