aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Sereal-Decoder/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/p5-Sereal-Decoder/Makefile')
-rw-r--r--converters/p5-Sereal-Decoder/Makefile32
1 files changed, 30 insertions, 2 deletions
diff --git a/converters/p5-Sereal-Decoder/Makefile b/converters/p5-Sereal-Decoder/Makefile
index 3c79d4d6740e..a66baa4c12c3 100644
--- a/converters/p5-Sereal-Decoder/Makefile
+++ b/converters/p5-Sereal-Decoder/Makefile
@@ -1,5 +1,33 @@
PORTNAME= Sereal-Decoder
+PORTVERSION= 5.004
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:YVES
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for fast, powerful binary deserialization (decoder)
+WWW= https://metacpan.org/pod/Sereal::Decoder
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libzstd.so:archivers/zstd
+TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep \
+ p5-Test-Differences>=0,1:devel/p5-Test-Differences \
+ p5-Test-LongString>=0:devel/p5-Test-LongString \
+ p5-Test-Warn>=0:devel/p5-Test-Warn
+
+USES= perl5
+USE_PERL5= configure
+
+CONFIGURE_ENV= NO_ASM=no USE_UNALIGNED=no
+MAKE_ENV= PASTHRU_DEFINE="-I${LOCALBASE}/include"
+MAKE_JOBS_UNSAFE= yes
+
+PORTSCOUT= limit:^[0-9\.]*$$
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Sereal/Decoder/Decoder.so
-SLAVE_PORT= yes
-.include "${.CURDIR}/../p5-Sereal/Makefile"
+.include <bsd.port.mk>