aboutsummaryrefslogtreecommitdiff
path: root/databases/cassandra3/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/cassandra3/files')
-rw-r--r--databases/cassandra3/files/patch-build.xml119
-rw-r--r--databases/cassandra3/files/patch-conf_cassandra.yaml16
-rw-r--r--databases/cassandra3/files/patch-doc_Makefile11
-rw-r--r--databases/cassandra3/files/patch-doc_source___templates_indexcontent.html17
-rw-r--r--databases/cassandra3/files/patch-doc_source___util_cql.py10
-rw-r--r--databases/cassandra3/files/patch-pylib_cassandra-cqlsh-tests.sh37
-rw-r--r--databases/cassandra3/files/patch-pylib_requirements.txt16
-rw-r--r--databases/cassandra3/files/patch-src_java_org_apache_cassandra_tools_nodetool_Status.java4
8 files changed, 62 insertions, 168 deletions
diff --git a/databases/cassandra3/files/patch-build.xml b/databases/cassandra3/files/patch-build.xml
index c6bb818a1c09..6b406a5d7b31 100644
--- a/databases/cassandra3/files/patch-build.xml
+++ b/databases/cassandra3/files/patch-build.xml
@@ -1,14 +1,15 @@
---- build.xml.orig 2020-10-20 17:07:48 UTC
+--- build.xml.orig 2022-10-28 19:54:09 UTC
+++ build.xml
-@@ -23,6 +23,7 @@
+@@ -31,6 +31,8 @@
<property file="build.properties" />
<property file="build.properties.default" />
<property name="debuglevel" value="source,lines,vars"/>
+ <property name="pycmd" value="python"/>
++ <property name="rat.skip" value="true"/>
<!-- default version and SCM information -->
- <property name="base.version" value="3.11.9"/>
-@@ -80,14 +81,14 @@
+ <property name="base.version" value="3.11.14"/>
+@@ -85,7 +87,7 @@
<condition property="version" value="${base.version}">
<isset property="release"/>
</condition>
@@ -17,82 +18,15 @@
<property name="version.properties.dir"
value="${build.src.resources}/org/apache/cassandra/config/" />
<property name="final.name" value="${ant.project.name}-${version}"/>
-
- <!-- details of what version of Maven ANT Tasks to fetch -->
- <property name="maven-ant-tasks.version" value="2.1.3" />
-- <property name="maven-ant-tasks.local" value="${user.home}/.m2/repository/org/apache/maven/maven-ant-tasks"/>
-+ <property name="maven-ant-tasks.local" value="${localm2}/org/apache/maven/maven-ant-tasks"/>
- <property name="maven-ant-tasks.url"
- value="https://repo.maven.apache.org/maven2/org/apache/maven/maven-ant-tasks" />
- <!-- details of how and which Maven repository we publish to -->
-@@ -247,8 +248,7 @@
- <artifact:dependencies pathId="wikitext.classpath">
- <dependency groupId="com.datastax.wikitext" artifactId="wikitext-core-ant" version="1.3"/>
- <dependency groupId="org.fusesource.wikitext" artifactId="textile-core" version="1.3"/>
-- <remoteRepository refid="central"/>
-- <remoteRepository refid="apache"/>
-+ <localRepository path="${localm2}"/>
- </artifact:dependencies>
- <taskdef classpathref="wikitext.classpath" resource="wikitexttasks.properties" />
- <wikitext-to-html markupLanguage="Textile">
-@@ -261,6 +261,7 @@
- <target name="gen-doc" depends="maven-ant-tasks-init" description="Generate documentation">
+@@ -272,6 +274,7 @@
+ <target name="gen-doc" description="Generate documentation" depends="gen-asciidoc,generate-cql-html" unless="ant.gen-doc.skip">
<exec executable="make" osfamily="unix" dir="${doc.dir}">
<arg value="html"/>
+ <arg value="PYTHON_CMD=${pycmd}"/>
</exec>
- <exec executable="cmd" osfamily="dos" dir="${doc.dir}">
- <arg value="/c"/>
-@@ -303,10 +304,6 @@
- description="Initialize Maven ANT Tasks">
- <typedef uri="antlib:org.apache.maven.artifact.ant" classpathref="maven-ant-tasks.classpath" />
+ </target>
-- <!-- define the remote repositories we use -->
-- <artifact:remoteRepository id="central" url="${artifact.remoteRepository.central}"/>
-- <artifact:remoteRepository id="apache" url="${artifact.remoteRepository.apache}"/>
--
- <macrodef name="install">
- <attribute name="pomFile"/>
- <attribute name="file"/>
-@@ -706,16 +703,14 @@
- filesetId="build-dependency-jars"
- cacheDependencyRefs="true"
- dependencyRefsBuildFile="${build.dir}/build-dependencies.xml">
-- <remoteRepository refid="central"/>
-- <remoteRepository refid="apache"/>
-+ <localRepository path="${localm2}"/>
- </artifact:dependencies>
- <!-- retrieve -source.jar artifacts using the reference-pom with the artifacts that have these -->
- <artifact:dependencies pomRefId="build-deps-pom-sources"
- sourcesFilesetId="build-dependency-sources"
- cacheDependencyRefs="true"
- dependencyRefsBuildFile="${build.dir}/build-dependencies-sources.xml">
-- <remoteRepository refid="central"/>
-- <remoteRepository refid="apache"/>
-+ <localRepository path="${localm2}"/>
- </artifact:dependencies>
- <copy todir="${build.dir.lib}/jars">
- <fileset refid="build-dependency-jars"/>
-@@ -728,7 +723,7 @@
- <!-- code coverage tools -->
- <artifact:dependencies pomRefId="coverage-deps-pom"
- filesetId="coverage-dependency-jars">
-- <remoteRepository refid="central"/>
-+ <localRepository path="${localm2}"/>
- </artifact:dependencies>
- <copy todir="${build.dir.lib}/jars">
- <fileset refid="coverage-dependency-jars"/>
-@@ -749,8 +744,7 @@
- sourcesFilesetId="test-dependency-sources"
- cacheDependencyRefs="true"
- dependencyRefsBuildFile="${build.dir}/test-dependencies.xml">
-- <remoteRepository refid="apache"/>
-- <remoteRepository refid="central"/>
-+ <localRepository path="${localm2}"/>
- </artifact:dependencies>
- <copy todir="${test.lib}/jars">
- <fileset refid="test-dependency-jars"/>
-@@ -1045,6 +1039,88 @@
+@@ -924,6 +927,88 @@
</jar>
</target>
@@ -179,38 +113,5 @@
+ </target>
+
<!-- creates release tarballs -->
- <target name="artifacts" depends="jar,javadoc,gen-doc"
+ <target name="artifacts" depends="jar,gen-doc,build-test,stress-build-test,sources-jar"
description="Create Cassandra release artifacts">
-@@ -1644,8 +1720,7 @@
- <target name="rat-init" depends="maven-ant-tasks-init">
- <artifact:dependencies pathId="rat.classpath">
- <dependency groupId="org.apache.rat" artifactId="apache-rat-tasks" version="0.6" />
-- <remoteRepository refid="central"/>
-- <remoteRepository refid="apache"/>
-+ <localRepository path="${localm2}"/>
- </artifact:dependencies>
- <typedef uri="antlib:org.apache.rat.anttasks" classpathref="rat.classpath"/>
- </target>
-@@ -1794,8 +1869,8 @@
- <exec executable="nproc" outputproperty="cores.count" os="Linux,SunOS,Solaris" failifexecutionfails="false">
- <arg value="--all"/>
- </exec>
-- <!-- support for Mac OS X -->
-- <exec executable="sysctl" outputproperty="cores.count" os="Mac,Mac OS X,Darwin" failifexecutionfails="false">
-+ <!-- support for Mac OS X and FreeBSD -->
-+ <exec executable="sysctl" outputproperty="cores.count" os="Mac,Mac OS X,Darwin,FreeBSD" failifexecutionfails="false">
- <arg value="-n"/>
- <arg value="hw.ncpu"/>
- </exec>
-@@ -1815,6 +1890,11 @@
- <exec executable="sysctl" outputproperty="mem.size" os="Mac,Mac OS X,Darwin" failifexecutionfails="false">
- <arg value="-n"/>
- <arg value="hw.memsize"/>
-+ </exec>
-+ <!-- support for FreeBSD -->
-+ <exec executable="sysctl" outputproperty="mem.size" os="FreeBSD" failifexecutionfails="false">
-+ <arg value="-n"/>
-+ <arg value="hw.physmem"/>
- </exec>
- <echo message="Mem size : ${mem.size}"/>
- </target>
diff --git a/databases/cassandra3/files/patch-conf_cassandra.yaml b/databases/cassandra3/files/patch-conf_cassandra.yaml
index 6d878e8ab4c2..a38a0d3fbf95 100644
--- a/databases/cassandra3/files/patch-conf_cassandra.yaml
+++ b/databases/cassandra3/files/patch-conf_cassandra.yaml
@@ -1,6 +1,6 @@
---- conf/cassandra.yaml.orig 2019-02-02 22:09:01 UTC
+--- conf/cassandra.yaml.orig 2022-10-28 19:54:09 UTC
+++ conf/cassandra.yaml
-@@ -70,7 +70,7 @@ max_hints_delivery_threads: 2
+@@ -71,7 +71,7 @@ max_hints_delivery_threads: 2
# Directory where Cassandra should store hints.
# If not set, the default directory is $CASSANDRA_HOME/data/hints.
@@ -9,7 +9,7 @@
# How often hints should be flushed from the internal buffers to disk.
# Will *not* trigger fsync.
-@@ -187,13 +187,13 @@ partitioner: org.apache.cassandra.dht.Murmur3Partition
+@@ -188,13 +188,13 @@ partitioner: org.apache.cassandra.dht.Murmur3Partition
# will spread data evenly across them, subject to the granularity of
# the configured compaction strategy.
# If not set, the default directory is $CASSANDRA_HOME/data/data.
@@ -26,7 +26,7 @@
# Enable / disable CDC functionality on a per-node basis. This modifies the logic used
# for write path allocation rejection (standard: never reject. cdc: reject Mutation
-@@ -204,7 +204,7 @@ cdc_enabled: false
+@@ -205,7 +205,7 @@ cdc_enabled: false
# segment contains mutations for a CDC-enabled table. This should be placed on a
# separate spindle than the data directories. If not set, the default directory is
# $CASSANDRA_HOME/data/cdc_raw.
@@ -35,7 +35,7 @@
# Policy for data disk failures:
#
-@@ -305,20 +305,12 @@ key_cache_save_period: 14400
+@@ -306,20 +306,12 @@ key_cache_save_period: 14400
# Row cache implementation class name. Available implementations:
#
@@ -57,12 +57,12 @@
#
# Default value is 0, to disable row caching.
row_cache_size_in_mb: 0
-@@ -365,7 +357,7 @@ counter_cache_save_period: 7200
+@@ -366,7 +358,7 @@ counter_cache_save_period: 7200
# saved caches
# If not set, the default directory is $CASSANDRA_HOME/data/saved_caches.
-# saved_caches_directory: /var/lib/cassandra/saved_caches
+saved_caches_directory: /var/db/cassandra/saved_caches
- # commitlog_sync may be either "periodic" or "batch."
- #
+ # Number of seconds the server will wait for each cache (row, key, etc ...) to load while starting
+ # the Cassandra process. Setting this to a negative value is equivalent to disabling all cache loading on startup
diff --git a/databases/cassandra3/files/patch-doc_Makefile b/databases/cassandra3/files/patch-doc_Makefile
deleted file mode 100644
index 7f83c34a50e4..000000000000
--- a/databases/cassandra3/files/patch-doc_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.orig 2020-10-27 14:38:56 UTC
-+++ doc/Makefile
-@@ -17,7 +17,7 @@ I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) s
- YAML_DOC_INPUT=../conf/cassandra.yaml
- YAML_DOC_OUTPUT=source/configuration/cassandra_config_file.rst
-
--MAKE_CASSANDRA_YAML = python convert_yaml_to_rst.py $(YAML_DOC_INPUT) $(YAML_DOC_OUTPUT)
-+MAKE_CASSANDRA_YAML = ${PYTHON_CMD} convert_yaml_to_rst.py $(YAML_DOC_INPUT) $(YAML_DOC_OUTPUT)
-
- WEB_SITE_PRESENCE_FILE='source/.build_for_website'
-
diff --git a/databases/cassandra3/files/patch-doc_source___templates_indexcontent.html b/databases/cassandra3/files/patch-doc_source___templates_indexcontent.html
deleted file mode 100644
index 7d8a637c9653..000000000000
--- a/databases/cassandra3/files/patch-doc_source___templates_indexcontent.html
+++ /dev/null
@@ -1,17 +0,0 @@
---- doc/source/_templates/indexcontent.html.orig 2020-10-28 18:46:34 UTC
-+++ doc/source/_templates/indexcontent.html
-@@ -1,5 +1,12 @@
--{% extends "defindex.html" %}
--{% block tables %}
-+{% extends "layout.html" %}
-+{%- block htmltitle -%}
-+<title>{{ html_title }}</title>
-+{%- endblock -%}
-+{% block body %}
-+ <h1>{{ docstitle|e }}</h1>
-+ <p>
-+ {% trans %}Welcome! This is the documentation for Apache Cassandra {{ version }}.{% endtrans %}
-+ </p>
- <div id="wipwarning">This documentation is currently a work-in-progress and contains a number of TODO sections.
- <a href="{{ pathto("bugs") }}">Contributions</a> are welcome.</div>
-
diff --git a/databases/cassandra3/files/patch-doc_source___util_cql.py b/databases/cassandra3/files/patch-doc_source___util_cql.py
deleted file mode 100644
index b3898552dfcd..000000000000
--- a/databases/cassandra3/files/patch-doc_source___util_cql.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- doc/source/_util/cql.py.orig 2020-10-28 18:48:05 UTC
-+++ doc/source/_util/cql.py
-@@ -26,7 +26,6 @@ from pygments.lexer import Lexer, RegexLexer, do_inser
- from pygments.token import Punctuation, Whitespace, Error, \
- Text, Comment, Operator, Keyword, Name, String, Number, Generic, Literal
- from pygments.lexers import get_lexer_by_name, ClassNotFound
--from pygments.util import iteritems
-
- __all__ = [ 'CQLLexer' ]
-
diff --git a/databases/cassandra3/files/patch-pylib_cassandra-cqlsh-tests.sh b/databases/cassandra3/files/patch-pylib_cassandra-cqlsh-tests.sh
index 137c6014c092..b27df106f467 100644
--- a/databases/cassandra3/files/patch-pylib_cassandra-cqlsh-tests.sh
+++ b/databases/cassandra3/files/patch-pylib_cassandra-cqlsh-tests.sh
@@ -1,39 +1,54 @@
---- pylib/cassandra-cqlsh-tests.sh.orig 2020-10-20 17:07:48 UTC
+--- pylib/cassandra-cqlsh-tests.sh.orig 2022-01-03 17:11:14 UTC
+++ pylib/cassandra-cqlsh-tests.sh
@@ -1,4 +1,4 @@
-#!/bin/bash -x
+#!/usr/local/bin/bash -x
+ #
+ # Licensed to the Apache Software Foundation (ASF) under one
+ # or more contributor license agreements. See the NOTICE file
+@@ -15,7 +15,6 @@
+ # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
+-#
################################
#
-@@ -9,6 +9,8 @@
+@@ -24,9 +23,13 @@
+ ################################
+
WORKSPACE=$1
- PYTHON_VERSION=$2
- JAVA_HOME=$3
-+REPO_DIR=$4
-+PYTHON_CMD=$5
+-PYTHON_VERSION=$2
+-JAVA_HOME=$3
++JAVA_HOME=$2
++REPO_DIR=$3
++PYTHON_CMD=$4
++REPO_DIR=$5
++PYTHON_VERSION=python3
++
if [ "${WORKSPACE}" = "" ]; then
echo "Specify Cassandra source directory"
-@@ -48,7 +50,7 @@ fi
+ exit
+@@ -65,7 +68,7 @@ fi
# Loop to prevent failure due to maven-ant-tasks not downloading a jar..
for x in $(seq 1 3); do
- ant -buildfile ${CASSANDRA_DIR}/build.xml realclean jar
-+ ant -buildfile ${CASSANDRA_DIR}/build.xml -Dmaven.repo.local=${REPO_DIR} -Dlocalm2=${REPO_DIR} -Dpycmd=${PYTHON_CMD} realclean jar
++ ${ANT_CMD} -buildfile ${CASSANDRA_DIR}/build.xml realclean jar -Dmaven.repo.local=${REPO_DIR} -Dlocalm2=${REPO_DIR}
RETURN="$?"
if [ "${RETURN}" -eq "0" ]; then
break
-@@ -62,7 +64,7 @@ fi
+@@ -79,7 +82,7 @@ fi
# Set up venv with dtest dependencies
set -e # enable immediate exit if venv setup fails
-virtualenv --python=$PYTHON_VERSION venv
-+virtualenv --python=${PYTHON_CMD} venv
++virtualenv --python=$PYTHON_CMD venv
source venv/bin/activate
pip install -r ${CASSANDRA_DIR}/pylib/requirements.txt
pip freeze
-@@ -103,7 +105,7 @@ case "${pre_or_post_cdc}" in
+@@ -120,7 +123,7 @@ case "${pre_or_post_cdc}" in
;;
esac
diff --git a/databases/cassandra3/files/patch-pylib_requirements.txt b/databases/cassandra3/files/patch-pylib_requirements.txt
new file mode 100644
index 000000000000..27616df2d111
--- /dev/null
+++ b/databases/cassandra3/files/patch-pylib_requirements.txt
@@ -0,0 +1,16 @@
+--- pylib/requirements.txt.orig 2022-01-04 12:21:36 UTC
++++ pylib/requirements.txt
+@@ -1,7 +1,6 @@
+ # See python driver docs: futures and six have to be installed before
+ # cythonizing the driver, perhaps only on old pips.
+ # http://datastax.github.io/python-driver/installation.html#cython-based-extensions
+-futures
+ six>=0.12.0
+ -e git+https://github.com/datastax/python-driver.git@cassandra-test#egg=cassandra-driver
+ # Used ccm version is tracked by cassandra-test branch in ccm repo. Please create a PR there for fixes or upgrades to new releases.
+@@ -17,4 +16,4 @@ nose-test-select
+ parse
+ pycodestyle
+ psutil
+-thrift==0.9.3
++thrift==0.10.0
diff --git a/databases/cassandra3/files/patch-src_java_org_apache_cassandra_tools_nodetool_Status.java b/databases/cassandra3/files/patch-src_java_org_apache_cassandra_tools_nodetool_Status.java
index c2a3dcd724e4..5390ab1f59cd 100644
--- a/databases/cassandra3/files/patch-src_java_org_apache_cassandra_tools_nodetool_Status.java
+++ b/databases/cassandra3/files/patch-src_java_org_apache_cassandra_tools_nodetool_Status.java
@@ -1,6 +1,6 @@
---- src/java/org/apache/cassandra/tools/nodetool/Status.java.orig 2019-12-18 11:47:59 UTC
+--- src/java/org/apache/cassandra/tools/nodetool/Status.java.orig 2021-07-01 14:37:50 UTC
+++ src/java/org/apache/cassandra/tools/nodetool/Status.java
-@@ -188,7 +188,7 @@ public class Status extends NodeToolCmd
+@@ -190,7 +190,7 @@ public class Status extends NodeToolCmd
String addressPlaceholder = String.format("%%-%ds ", maxAddressLength);
buf.append("%s%s "); // status
buf.append(addressPlaceholder); // address