aboutsummaryrefslogtreecommitdiff
path: root/databases/couchdb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/couchdb/Makefile')
-rw-r--r--databases/couchdb/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 6b22a58621d6..6a0d976b6ff3 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= couchdb
DISTVERSION= 1.7.1
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= databases
MASTER_SITES= APACHE/couchdb/source/${DISTVERSION}
@@ -18,8 +19,8 @@ LIB_DEPENDS= libicudata.so:devel/icu \
libmozjs185.so:lang/spidermonkey185 \
libcurl.so:ftp/curl
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:misc/help2man \
- erlang>=15.b.01,2:lang/erlang
-RUN_DEPENDS= erlang>=15.b.01,2:lang/erlang
+ erlang-runtime19>=19.3:lang/erlang-runtime19
+RUN_DEPENDS= erlang-runtime19>=19.3:lang/erlang-runtime19
USES= cpe gmake libtool
USE_RC_SUBR= couchdb
@@ -28,11 +29,13 @@ PLIST_SUB= VERSION=${DISTVERSION}
CPE_VENDOR= apache
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
+CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang19/usr/include \
--localstatedir=/var \
--disable-init \
--with-js-include=${LOCALBASE}/include/js \
--with-js-lib=${LOCALBASE}/lib
+CONFIGURE_ENV+= ERL=${LOCALBASE}/lib/erlang19/bin/erl \
+ ERLC=${LOCALBASE}/lib/erlang19/bin/erlc
USERS= couchdb
GROUPS= couchdb