aboutsummaryrefslogtreecommitdiff
path: root/databases/couchdb3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/couchdb3/Makefile')
-rw-r--r--databases/couchdb3/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/databases/couchdb3/Makefile b/databases/couchdb3/Makefile
index 208386b5020c..9cc5e25469b6 100644
--- a/databases/couchdb3/Makefile
+++ b/databases/couchdb3/Makefile
@@ -1,6 +1,5 @@
PORTNAME= couchdb3
-PORTVERSION= 3.2.1
-PORTREVISION= 2
+PORTVERSION= 3.2.2
CATEGORIES= databases
MASTER_SITES= APACHE/couchdb/source/${DISTVERSION}
DISTNAME= apache-couchdb-${DISTVERSION}
@@ -14,7 +13,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= erlang-runtime${ERLVER}>=${ERLVER}.0:lang/erlang-runtime${ERLVER} \
rebar:devel/rebar
LIB_DEPENDS= libicudata.so:devel/icu \
- libmozjs-78.so:lang/spidermonkey78
+ libmozjs-91.so:lang/spidermonkey91
RUN_DEPENDS= erlang-runtime${ERLVER}>=${ERLVER}.0:lang/erlang-runtime${ERLVER}
USES= compiler:c++17-lang cpe gmake libtool ncurses
@@ -40,7 +39,7 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= --skip-deps \
--user ${USERS} \
--rebar ${LOCALBASE}/bin/rebar \
- --spidermonkey-version 78
+ --spidermonkey-version 91
ALL_TARGET= release