aboutsummaryrefslogtreecommitdiff
path: root/databases/ejdb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/ejdb/Makefile')
-rw-r--r--databases/ejdb/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/databases/ejdb/Makefile b/databases/ejdb/Makefile
new file mode 100644
index 000000000000..95da44a575e9
--- /dev/null
+++ b/databases/ejdb/Makefile
@@ -0,0 +1,31 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= ejdb
+PORTVERSION= 2.72
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Embeddable JSON database engine library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libiowow.so:databases/iowow \
+ libiwnet.so:net/iwnet
+
+USES= cmake compiler:c11
+USE_GITHUB= yes
+GH_ACCOUNT= Softmotions
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DCMAKE_LOCALBASE:PATH="${LOCALBASE}" \
+ -DBUILD_EXAMPLES:BOOL=OFF
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${GREP} -Rl --null '#include <ejdb2/iowow/' ${WRKSRC}/src | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's,ejdb2/iowow,iowow,'
+
+.include <bsd.port.mk>