aboutsummaryrefslogtreecommitdiff
path: root/databases/ejdb/files/patch-src_jbs_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'databases/ejdb/files/patch-src_jbs_CMakeLists.txt')
-rw-r--r--databases/ejdb/files/patch-src_jbs_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/databases/ejdb/files/patch-src_jbs_CMakeLists.txt b/databases/ejdb/files/patch-src_jbs_CMakeLists.txt
new file mode 100644
index 000000000000..af4b9e4c37e0
--- /dev/null
+++ b/databases/ejdb/files/patch-src_jbs_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/jbs/CMakeLists.txt.orig 2022-02-23 10:00:23 UTC
++++ src/jbs/CMakeLists.txt
+@@ -1,6 +1,7 @@
+ # Executables
+ add_executable(jbs jbs.c)
+-target_link_libraries(jbs ejdb2_s)
++target_link_libraries(jbs ejdb2_s iowow iwnet)
++target_link_directories(jbs PRIVATE "${CMAKE_LOCALBASE}/lib")
+
+ if(CMAKE_BUILD_TYPE STREQUAL "Release")
+ add_custom_command(