aboutsummaryrefslogtreecommitdiff
path: root/databases/freetds
diff options
context:
space:
mode:
Diffstat (limited to 'databases/freetds')
-rw-r--r--databases/freetds/Makefile61
-rw-r--r--databases/freetds/distinfo6
-rw-r--r--databases/freetds/files/patch-configure38
-rw-r--r--databases/freetds/files/patch-src_tds_sec__negotiate__openssl.h14
-rw-r--r--databases/freetds/files/patch-src_tds_tls.c38
-rw-r--r--databases/freetds/pkg-descr2
-rw-r--r--databases/freetds/pkg-plist18
7 files changed, 105 insertions, 72 deletions
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 9032d0598271..44bebb8eb972 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -1,7 +1,5 @@
-# Created by: Domas Mituzas <midom@dammit.lt>
-
PORTNAME= freetds
-PORTVERSION= 1.2.21
+PORTVERSION= 1.4.13
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= https://www.freetds.org/files/stable/ \
@@ -9,42 +7,51 @@ MASTER_SITES= https://www.freetds.org/files/stable/ \
MAINTAINER= bofh@FreeBSD.org
COMMENT= Sybase/Microsoft TDS protocol library
+WWW= http://www.freetds.org/
LICENSE= GPLv2
LIB_DEPENDS= libgcrypt.so:security/libgcrypt
-USES= autoreconf gettext gmake iconv libtool:keepla pkgconfig readline tar:bzip2
-
-TDS_VER?= 7.4
+USES= cpe gettext gmake iconv libtool:keepla localbase:ldflags \
+ pkgconfig readline tar:bzip2
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-LIBS+= -lgcrypt -lpthread
-CONFIGURE_ARGS= --with-tdsver=${TDS_VER} --sysconfdir=${ETCDIR} \
- --enable-sybase-compat --enable-msdblib
-USE_LDCONFIG= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
+CONFIGURE_ARGS= --enable-msdblib \
+ --enable-sybase-compat \
+ --sysconfdir=${ETCDIR} \
+ --with-tdsver=${TDS_VER}
+
INSTALL_TARGET= install-strip
+LIBS+= -lgcrypt -lpthread
+
+CONFLICTS= freetds-devel
+
PORTDOCS= *
OPTIONS_DEFINE= DOCS MARS
-OPTIONS_SINGLE= SSL ODBC
-OPTIONS_SINGLE_SSL= OPENSSL GNUTLS
-OPTIONS_DEFAULT= OPENSSL MARS UNIXODBC
+OPTIONS_DEFAULT= MARS OPENSSL UNIXODBC
+OPTIONS_SINGLE= ODBC SSL
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
-OPENSSL_USES= ssl
-OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
+OPTIONS_SINGLE_SSL= GNUTLS OPENSSL
+
+MARS_DESC= Enable MARS code (Experimental)
+
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_ON= --with-gnutls
IODBC_LIB_DEPENDS= libiodbc.so:databases/libiodbc
IODBC_CONFIGURE_ON= --with-iodbc=${LOCALBASE}
IODBC_CPPFLAGS= -I${LOCALBASE}/include/libiodbc
+MARS_CONFIGURE_ON= --enable-mars
+OPENSSL_USES= ssl
+OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
UNIXODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
UNIXODBC_CONFIGURE_ON= --with-unixodbc=${LOCALBASE}
-MARS_DESC= Enable MARS code (Experimental)
-MARS_CONFIGURE_ON= --enable-mars
+
+TDS_VER?= 7.4
.include <bsd.port.options.mk>
@@ -60,13 +67,15 @@ post-extract:
@cd ${WRKSRC}/src/pool && ${LN} -s pool.conf pool.conf.sample
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.am" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|/freetds.conf|/freetds.conf.sample|g ; \
- s|/locales.conf|/locales.conf.sample|g ; \
- s|/pool.conf|/pool.conf.sample|g ; \
- s| common.h||g'
- @${REINPLACE_CMD} -e 's|\($$with_iodbc/include\)|\1/libiodbc|g' \
- ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e 's|/freetds.conf|/freetds.conf.sample|g ; \
+ s|/locales.conf|/locales.conf.sample|g ; \
+ s| common.h||g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/pool.conf|/pool.conf.sample|g' \
+ ${WRKSRC}/src/pool/Makefile.in
+ @${REINPLACE_CMD} -e 's|\($$with_iodbc/include\)|\1/libiodbc|g ; \
+ s| odbcss.h||g' \
+ ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKSRC}/interfaces ${STAGEDIR}${ETCDIR}/interfaces.sample
diff --git a/databases/freetds/distinfo b/databases/freetds/distinfo
index dc1f004e17a2..7d8ce380af8d 100644
--- a/databases/freetds/distinfo
+++ b/databases/freetds/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620405579
-SHA256 (freetds-1.2.21.tar.bz2) = a5e6bbf6d6f3dc0816b19cbd08308d27a084b04926aaa05ac67f808ea07d3d8d
-SIZE (freetds-1.2.21.tar.bz2) = 2249434
+TIMESTAMP = 1715459306
+SHA256 (freetds-1.4.13.tar.bz2) = 4530ba865cc5bcefc7b69095ad6538d7e3aaf1c7315185edd1b5b0241bf7aa0b
+SIZE (freetds-1.4.13.tar.bz2) = 2401434
diff --git a/databases/freetds/files/patch-configure b/databases/freetds/files/patch-configure
new file mode 100644
index 000000000000..987a1c57c9f8
--- /dev/null
+++ b/databases/freetds/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig 2023-12-04 09:01:11 UTC
++++ configure
+@@ -19020,20 +19020,7 @@ fi
+ printf "%s\n" "#define HAVE_SQL_H 1" >>confdefs.h
+
+ fi
+-ac_fn_c_check_header_compile "$LINENO" "odbcss.h" "ac_cv_header_odbcss_h" "#ifdef HAVE_WINDOWS_H
+-# include <windows.h>
+-#endif
+-#ifdef HAVE_SQL_H
+-# include <sql.h>
+-#endif
+
+-"
+-if test "x$ac_cv_header_odbcss_h" = xyes
+-then :
+- printf "%s\n" "#define HAVE_ODBCSS_H 1" >>confdefs.h
+-
+-fi
+-
+ if test "$ac_cv_header_odbcss_h" = "yes"; then
+ HAVE_ODBCSS_H_TRUE=
+ HAVE_ODBCSS_H_FALSE='#'
+@@ -21342,7 +21329,7 @@ elif test "x$with_iodbc" != "x" -a "x$with_iodbc" != "
+ with_iodbc="$PWD/$with_iodbc"
+ fi
+ CPPFLAGS="$CPPFLAGS -DIODBC"
+- ODBC_INC="$with_iodbc/include"
++ ODBC_INC="$with_iodbc/include/libiodbc"
+ test -r "$ODBC_INC/isql.h" || as_fn_error $? "isql.h not found" "$LINENO" 5
+ test -r "$ODBC_INC/isqlext.h" || as_fn_error $? "isqlext.h not found" "$LINENO" 5
+ ODBC_INC="-I$ODBC_INC"
+@@ -26046,5 +26033,3 @@ fi
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: WARNING: unrecognized options: $ac_unrecognized_opts" >&5
+ printf "%s\n" "$as_me: WARNING: unrecognized options: $ac_unrecognized_opts" >&2;}
+ fi
+-
+-
diff --git a/databases/freetds/files/patch-src_tds_sec__negotiate__openssl.h b/databases/freetds/files/patch-src_tds_sec__negotiate__openssl.h
deleted file mode 100644
index 301e80834bf7..000000000000
--- a/databases/freetds/files/patch-src_tds_sec__negotiate__openssl.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/tds/sec_negotiate_openssl.h.orig 2017-02-15 09:00:01 UTC
-+++ src/tds/sec_negotiate_openssl.h
-@@ -37,6 +37,11 @@
- #error HAVE_OPENSSL not defines, this file should not be included
- #endif
-
-+#if defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
-+#undef OPENSSL_VERSION_NUMBER
-+#define OPENSSL_VERSION_NUMBER 0x1000107fL
-+#endif
-+
- static inline const BIGNUM*
- rsa_get_n(const RSA *rsa)
- {
diff --git a/databases/freetds/files/patch-src_tds_tls.c b/databases/freetds/files/patch-src_tds_tls.c
index 07a8cb8ec5ac..e9b18a332258 100644
--- a/databases/freetds/files/patch-src_tds_tls.c
+++ b/databases/freetds/files/patch-src_tds_tls.c
@@ -1,6 +1,6 @@
---- src/tds/tls.c.orig 2017-11-30 09:00:01 UTC
+--- src/tds/tls.c.orig 2023-11-24 09:00:02 UTC
+++ src/tds/tls.c
-@@ -50,6 +50,10 @@
+@@ -53,6 +53,10 @@
#include <sys/socket.h>
#endif
@@ -9,21 +9,23 @@
+#endif
+
#include <freetds/tds.h>
- #include <freetds/string.h>
+ #include <freetds/utils/string.h>
#include <freetds/tls.h>
-@@ -72,6 +76,15 @@
- #define SSL_PTR ptr
- #else
+@@ -600,7 +604,7 @@ tds_ssl_free(BIO *a)
+ return 1;
+ }
-+#ifdef LIBRESSL_VERSION_NUMBER
-+#if LIBRESSL_VERSION_NUMBER < 0x2070000FL
-+static pthread_mutex_t *openssllocks;
-+#undef OPENSSL_VERSION_NUMBER
-+#define OPENSSL_VERSION_NUMBER 0x1000107fL
-+#endif
-+#define TLS_ST_OK SSL_ST_OK
-+#endif
-+
- /* some compatibility layer */
- #if OPENSSL_VERSION_NUMBER < 0x1010000FL
- static inline void
+-#if OPENSSL_VERSION_NUMBER < 0x1010000FL || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x1010000FL
+ static BIO_METHOD tds_method_login[1] = {
+ {
+ BIO_TYPE_MEM,
+@@ -665,7 +669,7 @@ tds_deinit_openssl_methods(void)
+ # endif
+ #endif
+
+-#if OPENSSL_VERSION_NUMBER < 0x1010000FL || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x1010000FL
+ static tds_mutex *openssl_locks;
+
+ static void
diff --git a/databases/freetds/pkg-descr b/databases/freetds/pkg-descr
index c7edc70e6849..d854c2a9e423 100644
--- a/databases/freetds/pkg-descr
+++ b/databases/freetds/pkg-descr
@@ -1,5 +1,3 @@
This is TDS protocol library (CTlib/DBlib) that is used to connect to
Microsoft and Sybase SQL servers. This can be used instead of native
libraries, that are shipped with commercial products.
-
-WWW: http://www.freetds.org/
diff --git a/databases/freetds/pkg-plist b/databases/freetds/pkg-plist
index 277e7f237664..e7b2074e755e 100644
--- a/databases/freetds/pkg-plist
+++ b/databases/freetds/pkg-plist
@@ -31,15 +31,15 @@ lib/libsybdb.la
lib/libsybdb.so
lib/libsybdb.so.5
lib/libsybdb.so.5.1.0
-man/man1/bsqldb.1.gz
-man/man1/bsqlodbc.1.gz
-man/man1/datacopy.1.gz
-man/man1/defncopy.1.gz
-man/man1/fisql.1.gz
-man/man1/freebcp.1.gz
-man/man1/osql.1.gz
-man/man1/tsql.1.gz
-man/man5/freetds.conf.5.gz
+share/man/man1/bsqldb.1.gz
+share/man/man1/bsqlodbc.1.gz
+share/man/man1/datacopy.1.gz
+share/man/man1/defncopy.1.gz
+share/man/man1/fisql.1.gz
+share/man/man1/freebcp.1.gz
+share/man/man1/osql.1.gz
+share/man/man1/tsql.1.gz
+share/man/man5/freetds.conf.5.gz
%%ODBC%%bin/bsqlodbc
%%ODBC%%lib/libtdsodbc.so
%%ODBC%%lib/libtdsodbc.so.0