aboutsummaryrefslogtreecommitdiff
path: root/databases/gnome-db/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/gnome-db/Makefile')
-rw-r--r--databases/gnome-db/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
index 6636a06c844c..872231cf64ae 100644
--- a/databases/gnome-db/Makefile
+++ b/databases/gnome-db/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
USE_X_PREFIX= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -31,6 +31,8 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>