aboutsummaryrefslogtreecommitdiff
path: root/databases/grass8/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/grass8/Makefile')
-rw-r--r--databases/grass8/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/databases/grass8/Makefile b/databases/grass8/Makefile
index 89149dca84b0..77c4d4e3b569 100644
--- a/databases/grass8/Makefile
+++ b/databases/grass8/Makefile
@@ -1,6 +1,6 @@
PORTNAME= grass
-DISTVERSION= 8.0.0
-DISTVERSIONSUFFIX= RC1
+DISTVERSION= 8.3.2
+PORTREVISION= 2
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -16,11 +16,9 @@ MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
MASTER_SITE_SUBDIR= grass${VER}/source
PKGNAMESUFFIX= 8
-PATCH_SITES= https://github.com/osgeo/${PORTNAME}/commit/
-PATCHFILES= fbbf6c01ac97.patch:-p1 # https://github.com/OSGeo/grass/pull/2075 fix g.extension
-
MAINTAINER= lbartoletti@FreeBSD.org
COMMENT= Open source Geographical Information System (GIS)
+WWW= https://grass.osgeo.org/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
@@ -42,7 +40,7 @@ RUN_DEPENDS= ${PY_NUMPY} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
USES= blaslapack compiler:c11 gl gmake gnome iconv \
- jpeg perl5 pkgconfig python:3.6+ readline shebangfix sqlite xorg
+ jpeg perl5 pkgconfig python readline shebangfix sqlite xorg
SHEBANG_GLOB= *.py
SHEBANG_LANG= nviz
nviz_OLD_CMD= nviz
@@ -50,8 +48,8 @@ nviz_CMD= ${PREFIX}/${GRASS_INST_DIR}/bin/nviz
USE_XORG= sm ice x11 xext xi xmu xrender xt
USE_GL= gl glu
USE_GNOME= cairo
-USE_WX= 3.0
-WX_COMPS= wx:build python:run
+USE_WX= 3.2
+WX_COMPS= wx python:run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
@@ -108,20 +106,20 @@ NLS_USES= gettext
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
ODBC_CONFIGURE_WITH= odbc
PDAL_CONFIGURE_ON= --with-pdal=${LOCALBASE}/bin/pdal-config
-PDAL_LIB_DEPENDS= libpdal_base.so:math/pdal
+PDAL_LIB_DEPENDS= libpdalcpp.so:math/pdal
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgres
+.if exists(/usr/include/omp.h)
+CONFIGURE_ARGS+= --with-openmp
+.endif
+
.include <bsd.port.pre.mk>
.if !defined (GRASS_INST_DIR)
GRASS_INST_DIR= ${PORTNAME}${VER}
.endif
-.if ${ARCH} != powerpc
-CONFIGURE_ARGS+= --with-openmp
-.endif
-
MANDIRS= ${PREFIX}/grass${VER}/docs/man/man1
post-patch: