aboutsummaryrefslogtreecommitdiff
path: root/databases/immudb
diff options
context:
space:
mode:
Diffstat (limited to 'databases/immudb')
-rw-r--r--databases/immudb/Makefile33
-rw-r--r--databases/immudb/distinfo7
-rw-r--r--databases/immudb/pkg-descr6
-rw-r--r--databases/immudb/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/databases/immudb/Makefile b/databases/immudb/Makefile
new file mode 100644
index 000000000000..ba1fed5e1458
--- /dev/null
+++ b/databases/immudb/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= immudb
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.0
+PORTREVISION= 7
+CATEGORIES= databases net
+PKGNAMESUFFIX= ${DISTVERSION:R:S/.//}
+
+PATCH_SITES= https://github.com/codenotary/immudb/commit/
+PATCHFILES= 0df15e08d84e89509499a84d1b5266b5612c0301.patch:-p1
+
+MAINTAINER= ronald@FreeBSD.org
+COMMENT= Database with built-in cryptographic proof and verification
+WWW= https://immudb.io/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= bash:shells/bash
+
+USES= gmake go:modules,no_targets
+GO_MODULE= github.com/codenotary/immudb
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|g' ${WRKSRC}/Makefile
+
+do-install:
+.for f in immuadmin immuclient immudb immutest
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}/${PREFIX}/bin/${f}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/databases/immudb/distinfo b/databases/immudb/distinfo
new file mode 100644
index 000000000000..0f691bb209b3
--- /dev/null
+++ b/databases/immudb/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1687460511
+SHA256 (go/databases_immudb/immudb-v1.5.0/v1.5.0.mod) = 0b625efa9ff12cf898d6aca289132418011fa0d582bec3e6cba8ce8bb3072ea0
+SIZE (go/databases_immudb/immudb-v1.5.0/v1.5.0.mod) = 5067
+SHA256 (go/databases_immudb/immudb-v1.5.0/v1.5.0.zip) = 57d030659fdf5b6554990445d0630afa79d8e4fb985315d362d6db56192428e8
+SIZE (go/databases_immudb/immudb-v1.5.0/v1.5.0.zip) = 3146310
+SHA256 (go/databases_immudb/immudb-v1.5.0/0df15e08d84e89509499a84d1b5266b5612c0301.patch) = 0703b8f09b7077c3621650cae53655e9c8a03013420f42662c50aeaa5aac8a6e
+SIZE (go/databases_immudb/immudb-v1.5.0/0df15e08d84e89509499a84d1b5266b5612c0301.patch) = 947
diff --git a/databases/immudb/pkg-descr b/databases/immudb/pkg-descr
new file mode 100644
index 000000000000..5ac4ca4ecf84
--- /dev/null
+++ b/databases/immudb/pkg-descr
@@ -0,0 +1,6 @@
+Open source immutable database
+
+* High performance and easy to integrate
+* Supports both Key/Value & SQL
+* Cryptographical client-verification, tamper-resistant, and auditable
+* Versioned and temporal queries subject to cryptographic verification
diff --git a/databases/immudb/pkg-plist b/databases/immudb/pkg-plist
new file mode 100644
index 000000000000..2d0b292a016c
--- /dev/null
+++ b/databases/immudb/pkg-plist
@@ -0,0 +1,4 @@
+bin/immuadmin
+bin/immuclient
+bin/immudb
+bin/immutest