aboutsummaryrefslogtreecommitdiff
path: root/databases/libcouchbase/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/libcouchbase/Makefile')
-rw-r--r--databases/libcouchbase/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/databases/libcouchbase/Makefile b/databases/libcouchbase/Makefile
index 626328fee99a..24939460c84e 100644
--- a/databases/libcouchbase/Makefile
+++ b/databases/libcouchbase/Makefile
@@ -11,7 +11,6 @@ COMMENT= Multithreaded noSQL database (client and library)
LICENSE= APACHE20
BROKEN_mips64= fails to link: ld: failed to merge target specific data
-BROKEN_riscv64= fails to build: dt_modtext: libdtrace/common/dt_link.c(947): RISC-V implementation required
LIB_DEPENDS= libevent.so:devel/libevent \
libev.so:devel/libev \
@@ -25,7 +24,7 @@ CMAKE_ARGS= -DLCB_NO_TESTS=1
.include <bsd.port.pre.mk>
-.if ${ARCH} == aarch64 || ${ARCH} == armv6 || ${ARCH} == armv7
+.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH} == riscv64
CMAKE_ARGS+= -DDTRACE:BOOL=FALSE
.endif