aboutsummaryrefslogtreecommitdiff
path: root/databases/libcouchbase
diff options
context:
space:
mode:
Diffstat (limited to 'databases/libcouchbase')
-rw-r--r--databases/libcouchbase/Makefile14
-rw-r--r--databases/libcouchbase/distinfo6
-rw-r--r--databases/libcouchbase/files/patch-CMakeLists.txt20
-rw-r--r--databases/libcouchbase/files/patch-plugins_io_libuv_libuv__compat.h13
-rw-r--r--databases/libcouchbase/files/patch-src_lcbio_ioutils.cc14
-rw-r--r--databases/libcouchbase/files/patch-tools_cbc-proxy.cc17
-rw-r--r--databases/libcouchbase/pkg-descr2
-rw-r--r--databases/libcouchbase/pkg-plist93
8 files changed, 97 insertions, 82 deletions
diff --git a/databases/libcouchbase/Makefile b/databases/libcouchbase/Makefile
index 04a4773b638d..44c451af1c23 100644
--- a/databases/libcouchbase/Makefile
+++ b/databases/libcouchbase/Makefile
@@ -1,17 +1,19 @@
PORTNAME= libcouchbase
-PORTVERSION= 2.10.7
+PORTVERSION= 3.3.8
+PORTREVISION= 1
CATEGORIES= databases
-MASTER_SITES= http://packages.couchbase.com/clients/c/
+MASTER_SITES= https://github.com/couchbase/${PORTNAME}/releases/download/${PORTVERSION}/
MAINTAINER= sergey@couchbase.com
COMMENT= Multithreaded noSQL database (client and library)
+WWW= https://docs.couchbase.com/c-sdk/current/hello-world/start-using-sdk.html
LICENSE= APACHE20
-BROKEN_mips64= fails to link: ld: failed to merge target specific data
+BROKEN_mips64= fails to link: ld: failed to merge target specific data
-LIB_DEPENDS= libevent.so:devel/libevent \
- libev.so:devel/libev \
+LIB_DEPENDS= libev.so:devel/libev \
+ libevent.so:devel/libevent \
libuv.so:devel/libuv
USES= cmake perl5 ssl
@@ -20,6 +22,8 @@ USE_PERL5= build run
CMAKE_ARGS= -DLCB_NO_TESTS=1
+CONFLICTS_INSTALL= coin-or-cbc
+
.include <bsd.port.pre.mk>
.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH} == riscv64
diff --git a/databases/libcouchbase/distinfo b/databases/libcouchbase/distinfo
index 5c7d9fd1700e..3a4d0747a241 100644
--- a/databases/libcouchbase/distinfo
+++ b/databases/libcouchbase/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592402966
-SHA256 (libcouchbase-2.10.7.tar.gz) = bbee97ef2394f275b8cd4b9b940010566a2d34d4754ba3532a7fca3d94029b75
-SIZE (libcouchbase-2.10.7.tar.gz) = 1345574
+TIMESTAMP = 1692385531
+SHA256 (libcouchbase-3.3.8.tar.gz) = 5e29ab6bfc5c1fe4f54450f6285cc36de8fff4bf2d39dd16d17aa47cbb9ff88a
+SIZE (libcouchbase-3.3.8.tar.gz) = 1491492
diff --git a/databases/libcouchbase/files/patch-CMakeLists.txt b/databases/libcouchbase/files/patch-CMakeLists.txt
index da30e2e7b71d..5a1ba2f57f57 100644
--- a/databases/libcouchbase/files/patch-CMakeLists.txt
+++ b/databases/libcouchbase/files/patch-CMakeLists.txt
@@ -1,16 +1,16 @@
---- CMakeLists.txt.orig 2015-08-27 15:51:35 UTC
+--- CMakeLists.txt.orig 2023-08-16 20:12:55 UTC
+++ CMakeLists.txt
-@@ -371,6 +371,7 @@ INSTALL(DIRECTORY include/libcouchbase $
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
- FILES_MATCHING PATTERN *.h PATTERN *.c)
-
-+set(CMAKE_INSTALL_MANDIR "man")
- INSTALL(DIRECTORY doc/man/ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 FILES_MATCHING PATTERN *.1)
- INSTALL(DIRECTORY doc/man/ DESTINATION ${CMAKE_INSTALL_MANDIR}/man4 FILES_MATCHING PATTERN *.4)
+@@ -484,6 +484,7 @@ IF(LCB_INSTALL_HEADERS)
+ ENDIF()
-@@ -382,7 +383,7 @@ SET(_lcb_manifest "${LCB_GENINFODIR}/MAN
+ IF(NOT LCB_NO_TOOLS)
++ set(CMAKE_INSTALL_MANDIR "share/man")
+ INSTALL(DIRECTORY doc/man/ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 FILES_MATCHING PATTERN *.1)
+ INSTALL(DIRECTORY doc/man/ DESTINATION ${CMAKE_INSTALL_MANDIR}/man4 FILES_MATCHING PATTERN *.4)
+ ENDIF()
+@@ -503,7 +504,7 @@ SET(_lcb_manifest "${LCB_GENINFODIR}/MANIFEST")
# pkg-config stuff goes with installation
- IF(NOT WIN32)
+ IF(NOT WIN32 AND LCB_INSTALL_PKGCONFIG)
CONFIGURE_FILE(packaging/libcouchbase.pc.in packaging/libcouchbase.pc @ONLY)
- INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/libcouchbase.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/libcouchbase.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}data/pkgconfig)
diff --git a/databases/libcouchbase/files/patch-plugins_io_libuv_libuv__compat.h b/databases/libcouchbase/files/patch-plugins_io_libuv_libuv__compat.h
new file mode 100644
index 000000000000..c082286f2d92
--- /dev/null
+++ b/databases/libcouchbase/files/patch-plugins_io_libuv_libuv__compat.h
@@ -0,0 +1,13 @@
+--- plugins/io/libuv/libuv_compat.h.orig 2023-06-03 18:58:46 UTC
++++ plugins/io/libuv/libuv_compat.h
+@@ -35,6 +35,10 @@
+ #define UNKNOWN -1
+ #endif
+
++#ifndef ENODATA
++#define ENODATA EPIPE
++#endif
++
+ #ifndef EAIFAMNOSUPPORT
+ #define EAIFAMNOSUPPORT EAI_FAMILY
+ #endif
diff --git a/databases/libcouchbase/files/patch-src_lcbio_ioutils.cc b/databases/libcouchbase/files/patch-src_lcbio_ioutils.cc
index dc48546eb71c..57093aa31465 100644
--- a/databases/libcouchbase/files/patch-src_lcbio_ioutils.cc
+++ b/databases/libcouchbase/files/patch-src_lcbio_ioutils.cc
@@ -1,10 +1,12 @@
---- src/lcbio/ioutils.cc.orig 2020-06-17 13:30:27 UTC
+--- src/lcbio/ioutils.cc.orig 2022-12-09 14:14:27 UTC
+++ src/lcbio/ioutils.cc
-@@ -25,6 +25,7 @@
- #include "manager.h"
+@@ -24,6 +24,9 @@
+ #include "hostlist.h"
#include "iotable.h"
- #include <stdio.h>
-+#include <netinet/in.h>
#include "ssl.h"
++#ifdef __FreeBSD__
++#include <netinet/in.h>
++#endif
- lcbio_CSERR
+ lcbio_CSERR lcbio_mkcserr(int syserr)
+ {
diff --git a/databases/libcouchbase/files/patch-tools_cbc-proxy.cc b/databases/libcouchbase/files/patch-tools_cbc-proxy.cc
index 58f053571a60..39945c572511 100644
--- a/databases/libcouchbase/files/patch-tools_cbc-proxy.cc
+++ b/databases/libcouchbase/files/patch-tools_cbc-proxy.cc
@@ -1,10 +1,13 @@
---- tools/cbc-proxy.cc.orig 2020-06-17 13:30:27 UTC
+--- tools/cbc-proxy.cc.orig 2022-12-09 14:19:12 UTC
+++ tools/cbc-proxy.cc
-@@ -18,6 +18,7 @@
+@@ -35,6 +35,10 @@
+ #include <event2/bufferevent.h>
+ #include <event2/buffer.h>
- #include "config.h"
- #include <sys/types.h>
++#ifdef __FreeBSD__
+#include <netinet/in.h>
- #include <libcouchbase/couchbase.h>
- #include <libcouchbase/vbucket.h>
- #include <libcouchbase/api3.h>
++#endif
++
+ using namespace cbc;
+ using namespace cliopts;
+
diff --git a/databases/libcouchbase/pkg-descr b/databases/libcouchbase/pkg-descr
index ce6778201a69..d80d99754f26 100644
--- a/databases/libcouchbase/pkg-descr
+++ b/databases/libcouchbase/pkg-descr
@@ -1,5 +1,3 @@
This is the C client library for Couchbase. It communicates with the cluster
and speaks the relevant protocols necessary to connect to the cluster and
execute data operations.
-
-WWW: https://developer.couchbase.com/documentation/server/current/sdk/c/start-using-sdk.html
diff --git a/databases/libcouchbase/pkg-plist b/databases/libcouchbase/pkg-plist
index 275ff95d6e58..77350377fc07 100644
--- a/databases/libcouchbase/pkg-plist
+++ b/databases/libcouchbase/pkg-plist
@@ -3,15 +3,18 @@ bin/cbc-admin
bin/cbc-bucket-create
bin/cbc-bucket-delete
bin/cbc-bucket-flush
+bin/cbc-bucket-list
bin/cbc-cat
+bin/cbc-collection-id
+bin/cbc-collection-manifest
bin/cbc-connstr
bin/cbc-create
bin/cbc-decr
+bin/cbc-gen
bin/cbc-hash
bin/cbc-incr
bin/cbc-keygen
bin/cbc-lock
-bin/cbc-mcflush
bin/cbc-mcversion
bin/cbc-n1ql
bin/cbc-n1qlback
@@ -35,29 +38,23 @@ bin/cbc-version
bin/cbc-view
bin/cbc-watch
bin/cbc-write-config
-include/libcouchbase/_cxxwrap.h
-include/libcouchbase/analytics.h
-include/libcouchbase/api-legacy.h
-include/libcouchbase/api3.h
include/libcouchbase/assert.h
include/libcouchbase/auth.h
-include/libcouchbase/cbft.h
include/libcouchbase/cntl-private.h
include/libcouchbase/cntl.h
include/libcouchbase/configuration.h
include/libcouchbase/couchbase.h
include/libcouchbase/crypto.h
-include/libcouchbase/deprecated.h
include/libcouchbase/error.h
-include/libcouchbase/http.h
+include/libcouchbase/iometrics.h
include/libcouchbase/iops.h
include/libcouchbase/ixmgmt.h
include/libcouchbase/kvbuf.h
include/libcouchbase/libev_io_opts.h
include/libcouchbase/libevent_io_opts.h
include/libcouchbase/libuv_io_opts.h
+include/libcouchbase/logger.h
include/libcouchbase/metrics.h
-include/libcouchbase/n1ql.h
include/libcouchbase/pktfwd.h
include/libcouchbase/plugins/io/bsdio-inl.c
include/libcouchbase/plugins/io/libuv/libuv_compat.h
@@ -66,49 +63,47 @@ include/libcouchbase/plugins/io/libuv/plugin-libuv.c
include/libcouchbase/plugins/io/wsaerr-inl.c
include/libcouchbase/plugins/io/wsaerr.h
include/libcouchbase/select_io_opts.h
-include/libcouchbase/subdoc.h
include/libcouchbase/sysdefs.h
include/libcouchbase/tracing.h
+include/libcouchbase/utils.h
include/libcouchbase/vbucket.h
-include/libcouchbase/views.h
include/libcouchbase/visibility.h
lib/libcouchbase.so
-lib/libcouchbase.so.2
-lib/libcouchbase.so.2.0.69
-lib/libcouchbase_libev.so
-lib/libcouchbase_libevent.so
-lib/libcouchbase_libuv.so
+lib/libcouchbase.so.8
+lib/libcouchbase.so.8.0.16
+lib/libcouchbase/libcouchbase_libev.so
+lib/libcouchbase/libcouchbase_libevent.so
+lib/libcouchbase/libcouchbase_libuv.so
libdata/pkgconfig/libcouchbase.pc
-man/man1/cbc-admin.1.gz
-man/man1/cbc-bucket-create.1.gz
-man/man1/cbc-bucket-delete.1.gz
-man/man1/cbc-cat.1.gz
-man/man1/cbc-connstr.1.gz
-man/man1/cbc-cp.1.gz
-man/man1/cbc-create.1.gz
-man/man1/cbc-decr.1.gz
-man/man1/cbc-flush.1.gz
-man/man1/cbc-hash.1.gz
-man/man1/cbc-incr.1.gz
-man/man1/cbc-lock.1.gz
-man/man1/cbc-mcflush.1.gz
-man/man1/cbc-mcversion.1.gz
-man/man1/cbc-n1ql.1.gz
-man/man1/cbc-n1qlback.1.gz
-man/man1/cbc-observe.1.gz
-man/man1/cbc-pillowfight.1.gz
-man/man1/cbc-ping.1.gz
-man/man1/cbc-rm.1.gz
-man/man1/cbc-role-list.1.gz
-man/man1/cbc-stats.1.gz
-man/man1/cbc-subdoc.1.gz
-man/man1/cbc-unlock.1.gz
-man/man1/cbc-user-delete.1.gz
-man/man1/cbc-user-list.1.gz
-man/man1/cbc-user-upsert.1.gz
-man/man1/cbc-verbosity.1.gz
-man/man1/cbc-version.1.gz
-man/man1/cbc-view.1.gz
-man/man1/cbc-watch.1.gz
-man/man1/cbc.1.gz
-man/man4/cbcrc.4.gz
+share/man/man1/cbc-admin.1.gz
+share/man/man1/cbc-bucket-create.1.gz
+share/man/man1/cbc-bucket-delete.1.gz
+share/man/man1/cbc-cat.1.gz
+share/man/man1/cbc-connstr.1.gz
+share/man/man1/cbc-cp.1.gz
+share/man/man1/cbc-create.1.gz
+share/man/man1/cbc-decr.1.gz
+share/man/man1/cbc-flush.1.gz
+share/man/man1/cbc-hash.1.gz
+share/man/man1/cbc-incr.1.gz
+share/man/man1/cbc-lock.1.gz
+share/man/man1/cbc-mcversion.1.gz
+share/man/man1/cbc-n1ql.1.gz
+share/man/man1/cbc-n1qlback.1.gz
+share/man/man1/cbc-observe.1.gz
+share/man/man1/cbc-pillowfight.1.gz
+share/man/man1/cbc-ping.1.gz
+share/man/man1/cbc-rm.1.gz
+share/man/man1/cbc-role-list.1.gz
+share/man/man1/cbc-stats.1.gz
+share/man/man1/cbc-subdoc.1.gz
+share/man/man1/cbc-unlock.1.gz
+share/man/man1/cbc-user-delete.1.gz
+share/man/man1/cbc-user-list.1.gz
+share/man/man1/cbc-user-upsert.1.gz
+share/man/man1/cbc-verbosity.1.gz
+share/man/man1/cbc-version.1.gz
+share/man/man1/cbc-view.1.gz
+share/man/man1/cbc-watch.1.gz
+share/man/man1/cbc.1.gz
+share/man/man4/cbcrc.4.gz