aboutsummaryrefslogtreecommitdiff
path: root/databases/libodbc++/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/libodbc++/Makefile')
-rw-r--r--databases/libodbc++/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/databases/libodbc++/Makefile b/databases/libodbc++/Makefile
index 43394c9c2f8b..f677de7d67cd 100644
--- a/databases/libodbc++/Makefile
+++ b/databases/libodbc++/Makefile
@@ -4,28 +4,31 @@ PORTREVISION= 5
CATEGORIES= databases devel
MASTER_SITES= SF/libodbcxx/libodbc%2B%2B/${PORTVERSION}
-MAINTAINER= fjoe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= C++ class library and toolset for ODBC access to data sources
+WWW= http://orcane.net/freeodbc++/
LICENSE= GPLv2
-OPTIONS_DEFINE= DOXYGEN DOCS
-
-DOXYGEN_IMPLIES= DOCS
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+LIB_DEPENDS= libodbc.so:databases/unixODBC
USES= gmake libtool ncurses pathfix pkgconfig readline tar:bzip2
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-isqlxx
-INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --with-isqlxx --with-odbc=${LOCALBASE}
-LIB_DEPENDS= libodbc.so:databases/unixODBC
-CONFIGURE_ARGS+= --with-odbc=${LOCALBASE}
+INSTALL_TARGET= install-strip
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= progref
+OPTIONS_DEFINE= DOXYGEN DOCS
+
+DOXYGEN_IMPLIES= DOCS
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+
post-extract:
${RM} ${WRKSRC}/doc/progref/progref-stamp