aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql57-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql57-server/Makefile')
-rw-r--r--databases/mysql57-server/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index 06fdb430ddee..36e5fb57ad01 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -20,8 +20,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SLAVEDIRS= databases/mysql57-client
USES= bison:build cmake:noninja compiler:c11 compiler:c++11-lib \
cpe groff:run libedit localbase perl5 shebangfix ssl
-IGNORE_SSL= openssl30 openssl31
-IGNORE_SSL_REASON= Upstream only supports OpenSSL 1.0.1 upto 1.1.X
CPE_VENDOR= oracle
USE_PERL5= run
@@ -150,6 +148,10 @@ CMAKE_ARGS+= -DWITH_AUTHENTICATION_LDAP=0
.include <bsd.port.pre.mk>
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
+IGNORE= Upstream only supports OpenSSL 1.0.1 upto 1.1.X
+.endif
+
.if ${SSL_DEFAULT} == base
CMAKE_ARGS+= -DWITH_SSL=system
.else