aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Browse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBIx-Browse/Makefile')
-rw-r--r--databases/p5-DBIx-Browse/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/p5-DBIx-Browse/Makefile b/databases/p5-DBIx-Browse/Makefile
index 9f1a44e8f11c..c05f1e1e832c 100644
--- a/databases/p5-DBIx-Browse/Makefile
+++ b/databases/p5-DBIx-Browse/Makefile
@@ -15,12 +15,20 @@ PKGNAMEPREFIX= p5-
MAINTAINER= philip@p6m7g8.com
COMMENT= DBIx::Browse - Perl extension to browse tables
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-
PERL_CONFIGURE= yes
MAN3= DBIx::Browse::CGI.3 \
DBIx::Browse.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>