aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBIx-Simple/Makefile')
-rw-r--r--databases/p5-DBIx-Simple/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/databases/p5-DBIx-Simple/Makefile b/databases/p5-DBIx-Simple/Makefile
index 3ff489e958e6..91dd36c1e7b7 100644
--- a/databases/p5-DBIx-Simple/Makefile
+++ b/databases/p5-DBIx-Simple/Makefile
@@ -6,32 +6,33 @@
#
PORTNAME= DBIx-Simple
-PORTVERSION= 1.26
+PORTVERSION= 1.32
CATEGORIES= databases perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= DBIx
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= parv@pair.com
COMMENT= Simplified object oriented interface to Perl DBI
-RUN_DEPENDS= p5-DBI>=1.21:${PORTSDIR}/databases/p5-DBI \
- p5-Data-Swap>=0.02:${PORTSDIR}/devel/p5-Data-Swap
+RUN_DEPENDS= p5-DBI>=1.21:${PORTSDIR}/databases/p5-DBI
-OPTIONS= \
- SQL_ABSTRACT "Generate SQL from Perl data structures" off \
- DBIX_XHTML_TABLE "Create XHTML tables from SQL queries" off \
- TEXT_TABLE "Create plain text table from data" off
+OPTIONS= SQL_INTERP "Interpolate Perl variables into SQL with DBI" off \
+ SQL_ABSTRACT "Generate SQL from Perl data structures" off \
+ DBIX_XHTML_TABLE "Create XHTML tables from SQL queries" off \
+ TEXT_TABLE "Create plain text table from data" off
PERL_CONFIGURE= yes
MAN3= DBIx::Simple.3 \
DBIx::Simple::Examples.3 \
- DBIx::Simple::Comparison.3 \
- DBIx::Simple::SQE.3
+ DBIx::Simple::Comparison.3
.include <bsd.port.pre.mk>
+.if defined(WITH_SQL_INTERP)
+RUN_DEPENDS+= ${SITE_PERL}/SQL/Interp.pm:${PORTSDIR}/databases/p5-SQL-Interp
+.endif
+
.if defined(WITH_SQL_ABSTRACT)
RUN_DEPENDS+= p5-SQL-Abstract>=0:${PORTSDIR}/databases/p5-SQL-Abstract
.endif