aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-POE-Component-DBIAgent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-POE-Component-DBIAgent/Makefile')
-rw-r--r--databases/p5-POE-Component-DBIAgent/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/databases/p5-POE-Component-DBIAgent/Makefile b/databases/p5-POE-Component-DBIAgent/Makefile
index 7d87457a958c..a2fd31cadd1f 100644
--- a/databases/p5-POE-Component-DBIAgent/Makefile
+++ b/databases/p5-POE-Component-DBIAgent/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= POE Component for running asynchronous DBI calls
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -27,4 +26,14 @@ MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= POE::Component::DBIAgent.3 POE::Component::DBIAgent::Helper.3 \
POE::Component::DBIAgent::Queue.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>