aboutsummaryrefslogtreecommitdiff
path: root/databases/percona56-server/files/patch-libmysql_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'databases/percona56-server/files/patch-libmysql_CMakeLists.txt')
-rw-r--r--databases/percona56-server/files/patch-libmysql_CMakeLists.txt43
1 files changed, 0 insertions, 43 deletions
diff --git a/databases/percona56-server/files/patch-libmysql_CMakeLists.txt b/databases/percona56-server/files/patch-libmysql_CMakeLists.txt
deleted file mode 100644
index 07bcdd4863bf..000000000000
--- a/databases/percona56-server/files/patch-libmysql_CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
---- libmysql/CMakeLists.txt.orig
-+++ libmysql/CMakeLists.txt
-@@ -205,7 +205,7 @@
- ENDIF()
-
- # Merge several convenience libraries into one big perconaserverclient
--MERGE_LIBRARIES(perconaserverclient STATIC ${LIBS_TO_MERGE} COMPONENT Development)
-+MERGE_LIBRARIES(perconaserverclient STATIC ${LIBS_TO_MERGE} COMPONENT Development NOINSTALL)
- TARGET_LINK_LIBRARIES(perconaserverclient ${LIBS_TO_LINK})
-
- # Visual Studio users need debug static library for debug projects
-@@ -220,6 +220,7 @@
- SET(${out_name} ${name})
- ENDMACRO()
-
-+IF(FALSE)
- IF(UNIX)
- MACRO(GET_VERSIONED_LIBNAME LIBNAME EXTENSION VERSION OUTNAME)
- SET(DOT_VERSION ".${VERSION}")
-@@ -240,14 +241,16 @@
- ${lib_name} ${CMAKE_STATIC_LIBRARY_PREFIX}perconaserverclient_r.a
- ${INSTALL_LIBDIR} Development)
- ENDIF()
-+ENDIF()
-
- IF(NOT DISABLE_SHARED)
- # Merge several convenience libraries into one big perconaserverclient
- # and link them together into shared library.
- MERGE_LIBRARIES(libmysql SHARED ${LIBS_TO_MERGE}
- EXPORTS ${CLIENT_API_FUNCTIONS}
-- COMPONENT SharedLibraries)
-+ COMPONENT SharedLibraries NOINSTALL)
- TARGET_LINK_LIBRARIES(libmysql ${LIBS_TO_LINK})
-+IF(FALSE)
- IF(UNIX)
- # libtool compatability
- IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
-@@ -316,4 +319,5 @@
- ${INSTALL_LIBDIR} SharedLibraries)
- ENDFOREACH()
- ENDIF()
-+ENDIF()
- ENDIF()