aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-orafce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-orafce/Makefile')
-rw-r--r--databases/postgresql-orafce/Makefile34
1 files changed, 10 insertions, 24 deletions
diff --git a/databases/postgresql-orafce/Makefile b/databases/postgresql-orafce/Makefile
index 6812e147d33d..a9d606153d1d 100644
--- a/databases/postgresql-orafce/Makefile
+++ b/databases/postgresql-orafce/Makefile
@@ -1,38 +1,24 @@
-# Created by: Jov <amutu@amutu.com>
-
-PORTNAME= orafce
+PORTNAME= orafce
DISTVERSIONPREFIX= VERSION_
-DISTVERSION= 3_13_4
-CATEGORIES= databases
-PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+DISTVERSION= 4_9_4
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Oracle's compatibility functions and packages for PostgreSQL
+WWW= https://github.com/orafce/orafce
-LICENSE= 0BSD
-LICENSE_NAME= Zero-Clause BSD / Free Public License 1.0.0
+LICENSE= BSD0CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT.orafce
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= gmake pgsql:9.5+
-USE_GITHUB= yes
-LLD_UNSAFE= yes
+USES= gmake pgsql
+LLD_UNSAFE= yes
WANT_PGSQL= server
-PORTDOCS= COPYRIGHT.orafce NEWS README.asciidoc
-
-OPTIONS_DEFINE= DOCS
-
-post-patch:
- ${REINPLACE_CMD} -e 's/DOCS = README/#&/' ${WRKSRC}/Makefile
+USE_GITHUB= yes
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/orafce.so
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- @(for f in ${PORTDOCS}; do \
- ${INSTALL_DATA} ${WRKSRC}/$${f} ${STAGEDIR}${DOCSDIR}; done)
-
.include <bsd.port.mk>